Pb WebBrowser

Signaler
Messages postés
38
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
31 décembre 2006
-
Messages postés
38
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
31 décembre 2006
-
Voila j'ai un pb assez urgent et assez important !
en effet pour mon code j'ai besoin d'actualiser souvent une form contenant un webbroswer.
Or a chaque chargement j'ai le droit a un petit bruit quand on actualise style "tic" et a la longue c'est vraiment ****
et en plus toute les secondes j'ai le curseur sablié qui apparait
voici mon code quie st dans un thread:

private void msgactu()
{
try
{
// Tant que le thread n'est pas tué, on travaille
while (Thread.CurrentThread.IsAlive)
{
Thread.Sleep(1000);//on actualise toute les secondes
string rekete;
create_rekete(out rekete);//url bien config
Uri conversurl = new Uri(rekete);
webBrowser1.Url = conversurl;
}
}
catch (Exception)
{ }
}

4 réponses

Messages postés
4030
Date d'inscription
mardi 13 mai 2003
Statut
Modérateur
Dernière intervention
23 décembre 2008
22
Salut,

Et ce petit 'tic', est ce que tu l'as en chargeant la même page dans un webbrowser classique (IE, Mozilla, .. ) ?


Manu
Messages postés
38
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
31 décembre 2006

oui c'est la meme chose
Messages postés
235
Date d'inscription
mercredi 30 octobre 2002
Statut
Membre
Dernière intervention
6 octobre 2009

Salut,

A tu trouvé la solution à ton problème ?
Car d'aprés certains sites : http://windowsclient.net/blogs/faqs/archive/tags/WebBrowser/default.aspx
Cela n'est pas possible d'enlever ce petit "TIC" à tu quand même réussi à trouvé une solution pour retirer ce tic ?

Merci d'avance.
Messages postés
38
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
31 décembre 2006

Non pas moyen, j'ai donc opté pour du rafraichissement ajax sur la page web