PROGRAMMATION DIRECT3D8 TUTORIAL 3 VERSION A : GEOMETRIE 3D SIMPLE

Signaler
Messages postés
780
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
16 avril 2009
-
cs_LaPatoshe
Messages postés
53
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
19 décembre 2009
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/17896-programmation-direct3d8-tutorial-3-version-a-geometrie-3d-simple

cs_LaPatoshe
Messages postés
53
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
19 décembre 2009

est ce que mes autres sur directX passent ?
Quels sont les paramètres que tu as changé sur cette source ?
TheIlluminati
Messages postés
24
Date d'inscription
samedi 7 juin 2003
Statut
Membre
Dernière intervention
29 octobre 2007

J'ai un méchant problème avec ta source, j'ai changé pas mal de paramètres pour voir, mais je n'ai rien, absolument rient qui s'affiche.
Pas d'erreur, la fenêtre est noire, comme si rien n'est dessiné.
Je ne comprends pas trop d'ou sa vient.
A+
cs_LaPatoshe
Messages postés
53
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
19 décembre 2009

Salut Rachid 777 et les autres. Vérifie que ton Device tel que tu l'as déclaré fonctione sans y dessiner dans un premier temps. Ensuite, si ton matériel est un peu ancien, essais d'utiliser plutôt des texctures 64*64 ou 128*128. Fais attention également à la texture lors de sa sauvegarde. Un dessin enregistré en Bmp peut ne pas fonctionner. J'ai eu ce problème, et j'ai dû charger un fichier de texture d'un logiciel 3D, redessiner dessus, et sauvegarder en Bmp. Vérifie que ton Bmp soit sauvegardé en couleurs 16 bits.
Voila, en espérant que ça pourra t'aider, sinon, donne moi un peu plus d'infos.
cs_LaPatoshe
Messages postés
53
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
19 décembre 2009

Salut Rachid 777 et les autres. Vérifie que ton Device tel que tu l'as déclaré fonctione sans y dessiner dans un premier temps. Ensuite, si ton matériel est un peu ancien, essais d'utiliser plutôt des texctures 64*64 ou 128*128. Fais attention également à la texture lors de sa sauvegarde. Un dessin enregistré en Bmp peut ne pas fonctionner. J'ai eu ce problème, et j'ai dû charger un fichier de texture d'un logiciel 3D, redessiner dessus, et sauvegarder en Bmp. Vérifie que ton Bmp soit sauvegardé en couleurs 16 bits.
Voila, en espérant que ça pourra t'aider, sinon, donne moi un peu plus d'infos.
cs_rachid777
Messages postés
12
Date d'inscription
vendredi 30 janvier 2004
Statut
Membre
Dernière intervention
17 mars 2004

Bonjour
j'ai toujours une erreur d'automation au niveau de la création des textures, malgré que j'utilise comme tu le dis la fonction CreateTextureFromFileEx en changeant les paramètres à 128 ou 256 ou 512. Y-at-il une autre solution? J'ai essayé aussi de manipuler les paramètres au niveau de la création du device, mais rien n'y fait. Pourtant ma carte graphique (de 8 Mo) apparemment supporte les textures puisque dans les tests de DirectX (DirextX Diagnostic Tools), le test sur AGPTexturing pour tester l'accéleration des textures AGP fonctionne très bien.
cs_Lightness1024!
Messages postés
162
Date d'inscription
jeudi 15 mars 2001
Statut
Membre
Dernière intervention
1 avril 2005

j'avais déja proposé une meme série de tutoriels equivalents en DX8.
c bien kil y en ait plusieurs mais il aurait mieu valu que toutes les nouvelles sources de la categorie soient en DX9!
(meme si les 2 versions sont quasi identiques)
cs_Urgo
Messages postés
780
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
16 avril 2009
1
Bravo à toi pour la source ! 10/1
En attendant la suite !