JOUER UNE MUSIQUE MODULE (MOD, XM, S3M,...)

Signaler
Messages postés
2226
Date d'inscription
dimanche 5 octobre 2003
Statut
Modérateur
Dernière intervention
18 novembre 2010
-
Messages postés
2226
Date d'inscription
dimanche 5 octobre 2003
Statut
Modérateur
Dernière intervention
18 novembre 2010
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/11721-jouer-une-musique-module-mod-xm-s3m

Messages postés
2226
Date d'inscription
dimanche 5 octobre 2003
Statut
Modérateur
Dernière intervention
18 novembre 2010
14
ha bon c rien :p
je passe mon tour :D
j'ai utilise le code de whiteshadow ki n'utilise pas de dll

merci qd meme !
bye
Messages postés
21041
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
30
Faut revoir ta fonction 'fileexists', pas parce qu'un fichier est en utilisation qu'on ne peut pas savoir s'il existe.
Messages postés
2226
Date d'inscription
dimanche 5 octobre 2003
Statut
Modérateur
Dernière intervention
18 novembre 2010
14
hello,

j'ai un soucis avec cette DLL :/
je m'explique :
- je la mets ds win\system : ok pas de pb, ça rox le compo !
- je ne la mets pas : erreur, dll manquante : logique :) donc dans ma source je mets la DLL en ressource, a l'execution de copie la dll ds le win\sys et HOP ! ça marche
MAIS ya un MAIS ...
si la DLL est deja presente ça chie ! DONC car ya un DONC je fais un simple verif :
if fileexists(dossierWindowsSystem+'npmod32.dll') then exit;
mais euh dans tous les cas il me dis "false" car la DLL etant en utilisation, il ne la voie pas ! enfin voila :(

en fait j'en viens a demander : comment faire qqchose de correct pour essayer de copier un fichier et eviter l'erreur du genre "POUF !! fichier en utilisation, degage cretin"

merci a vous :'(