RÉCUPÉRATION DU CODE HTML D'UNE URL VIA JMAIL.

cs_Bud
Messages postés
224
Date d'inscription
vendredi 14 septembre 2001
Statut
Membre
Dernière intervention
14 juillet 2006
- 11 août 2003 à 18:07
_Thy_
Messages postés
33
Date d'inscription
mardi 24 août 2004
Statut
Membre
Dernière intervention
19 septembre 2005
- 10 nov. 2005 à 11:27
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/9077-recuperation-du-code-html-d-une-url-via-jmail

_Thy_
Messages postés
33
Date d'inscription
mardi 24 août 2004
Statut
Membre
Dernière intervention
19 septembre 2005

10 nov. 2005 à 11:27
Excellente solution mais je n'ai ni Jmail ni la possibilité de l'installer, ni bien sur .Net

Pour ceux qui sont dans mo cas (en asp "tout court") j'ai trouvé ceci qui fonctionne bien :
http://www.aspfaq.com/show.asp?id=2173
cs_Targos
Messages postés
26
Date d'inscription
samedi 18 janvier 2003
Statut
Membre
Dernière intervention
7 juillet 2008

26 févr. 2004 à 15:35
Ca marche pas avec un lien ASP.NET (.aspx) !!!!!

Quelqu'un a la solution ?
cs_Yannick74
Messages postés
9
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
26 février 2007

12 août 2003 à 14:14
Peut être qu'il faut faire un mail.execute
En effet j'ai été surpris que le code de la page soit rapatrié directement sur le GetMessageBodyFromURL.

Je pense que dans ta version, le code ne sera rapatrié que sur un mail.execute , il faut voir si sans les paramètres minimum (serveur SMTP, adresse mail du SENDER et un DESTINATAIRE) ca peut marcher.

Sinon tu devras en plus renseignez tous ces paramètres (voir doc) pour que ca marche.

Et je te dis tous çà sans pouvoir tester.
cs_Bud
Messages postés
224
Date d'inscription
vendredi 14 septembre 2001
Statut
Membre
Dernière intervention
14 juillet 2006

12 août 2003 à 13:53
Bon, j'ai la version 3.7 de Jmail, la fonction "GetMessageBodyFromURL" est implémentée, mais ça ne marche pas...
cs_Yannick74
Messages postés
9
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
26 février 2007

12 août 2003 à 08:24
Non je ne sais pas avec quelle version "minimum" de JMail ca marche.
Il y a juste a regarder dans la doc de ta version si la function "GetMessageBodyFromURL" est implémentée !

Fabrice, c'est vrai que j'ai cherché sur beaucoup de site, le problème se pose souvent, mais les solutions proposés sont souvent complexes.
Afficher les 7 commentaires