Besoin d'aide

Signaler
Messages postés
27
Date d'inscription
lundi 3 octobre 2005
Statut
Membre
Dernière intervention
28 mars 2006
-
Messages postés
27
Date d'inscription
lundi 3 octobre 2005
Statut
Membre
Dernière intervention
28 mars 2006
-
Bonjour j'ai le code suivant pour passer un formauliare en méthode post le problème c'est que cela ne faonctionne pas et je ne comprend pas
Voici mon code:
Sub test_OnClick()
option explicit
dim http, fso, fout, StrResult
dim url, corps
set fso = CreateObject("Scripting.FileSystemObject")
Set http = CreateObject("MSXML2.XMLHTTP")
http.URL = "http://fniweb2/GTA/Default1b.asp"
http.RequestMethod = "POST"
http.PostData = "NAME=CANO&VALUE=1326"
fso.CreateTextFile "testBody.txt", true, false ' ecraser + ascii
set fOut = fso.GetFile("testBody.txt").OpenAsTextStream(2, 0)' ecrire + ascii
fOut.Write http.ResponseText
fout.Close
fso.CreateTextFile "testStatus.txt", true, false ' ecraser + ascii
set fOut = fso.GetFile("testStatus.txt").OpenAsTextStream(2, 0)' ecrire + ascii
fOut.Write http.Status & ": " & http.StatusText
fOut.Close
set fOut = nothing
set fso = nothing
set http = nothing
end Sub

ensuite j'ai une form comme celle là
<form action="http://fniweb2/GTA/Default1b.asp"
method="post"
type="submit"
target=""
name="frm_BADGER"
>

</form>

et dans mon code de ma page j'ai une autre form
<FORM>

</FORM>

est ce que quelqu'un pourrait me dire ce qu'il ne vas pas svp

3 réponses

Messages postés
192
Date d'inscription
dimanche 5 janvier 2003
Statut
Membre
Dernière intervention
9 mars 2007
1
Bonjour,

Y'a beaucoup de choses qui ne vont pas... la premiere est qu'il n'y a rien qui poste ton formulaire, as-tu quleque part dans un de tes fomulaires, la ligne suivante :

TiK - MCAD.NET
http://www.objectif-services.com
http://www.ultimecms.com
Messages postés
27
Date d'inscription
lundi 3 octobre 2005
Statut
Membre
Dernière intervention
28 mars 2006

non c'est la derniere form qui est a l'intérieur de mon code merci pour l'info
Messages postés
27
Date d'inscription
lundi 3 octobre 2005
Statut
Membre
Dernière intervention
28 mars 2006

j'ai modifié mais cela ne fonctionne toujours pas. :(
je comprends pad en fait ce systeme de passage en méthode post avec l'objet xmlhttp