Problème Vitesse sur certain PC [Résolu]

Signaler
Messages postés
116
Date d'inscription
dimanche 26 septembre 2004
Statut
Membre
Dernière intervention
13 février 2008
-
Messages postés
116
Date d'inscription
dimanche 26 septembre 2004
Statut
Membre
Dernière intervention
13 février 2008
-
Bonjour à tous j'ai commencé un jeu en Open Gl,
Sur mon PC je tourne à 250 FPS ou 60 qd la synchro verticale est activé sur ma geforce, mais sur 2 autres PC qui sont capables de faire tourner de bons jeux 3D (GTA 3 ...) je tombe à 2 ou 0.67 FPS.

Quelqu'un aurait-il une piste de réflexion car je ne sais pas trop après quoi chercher ...

Merci d'avance

http://www.rc-bot.com/

2 réponses

Messages postés
146
Date d'inscription
jeudi 22 avril 2004
Statut
Membre
Dernière intervention
8 mars 2008
1
salut, essayes d'utiliser un maximum de listes precompilées, ca evite
d'avoir le temps de transfert des données a la carte +
compilation à chaque frame...

pour info, meme une liste deja compilée peux faire appel à une autre
liste, ca qui permet de modifier une liste qui contient juste les
modifications de vecteur (translate et rotate) comme ca, au lieu
d'appeler toutes les listes, il suffit de les relier entre elles et
d'appeler la premiere. en ayant pris soin de modifier les liste de
vecteur. ceci est valable pour un objet de structure complexe comme un
bras articulé ou un systeme solaire --->> voir les cours du
blue book.



une autre possibilité de ralentissement, c'est que tu utilises une
fonction qui n'est pas supportée par la carte graphique du deuxieme
pc. sinon je vois pas.



pense a reverifier le calcul du frame rate et de voir si ya pas une
boucle inutile dasn la boucle de rendu ( du genre tracer deux cent fois
le meme objet au meme endroit !!!)



pour le reste, ya du beau monde qui aura d'autres idée !



@++
Messages postés
116
Date d'inscription
dimanche 26 septembre 2004
Statut
Membre
Dernière intervention
13 février 2008

Bonjour, et bien je me suis aperçu ce matin qu'en fait le pilote de la carte garphique n'était pas à jour du tout (celui de microsoft par défaut beurk) donc maintenant c'est bon c débloqué.

En revanche je vais qd même regarder du coté des listes précompilées pour optimiser mon jeu, ça a l'air plus efficace. Pour l'instant j'envoie à chaque frame mes 2400 vertex et normales c pas terrible ... et encore c le début je n'ai pas encore tout mis.

http://www.rc-bot.com/