Installation mysql sur Debian 3.1 [Résolu]

Signaler
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009
-
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
-
Salut !



Je voudrais installer mysql sur mon serveur debian 3.1, mais j'ai cette erreur :



Starting MySQL database server: mysqld...failed.

Please take a look at the syslog.

/usr/bin/mysqladmin: connect to server at 'localhost' failed

error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)'

Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!



J'ai cherché un peu partout, mais je ne trouve pas de quoi ça pourrai venir.



En espérant que quelqu'un pourra m'aider.



Merci



Tilix.

24 réponses

Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Quelqu'un serai près à me faire l'installation de mon serveur ?

Apache2 - Php4 - Mysql ?
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,

supprime le fichier /var/run/mysqld/mysqld.sock et redémare ton serveur...

In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Je l'ai supprimé, j'ai relancé le serveur, il me l'a recréé, avec toujours la même erreur.
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
essayes de faire ceci :

chmod 777 /var/run/mysqld/mysqld.sock

puis

chmod +x /var/run/mysqld/mysqld.sock



Si ça ne marche toujours pas ben... Essayes de réinstaller mysql on ne sait jamais..

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,

thomvaill, ça ne vient pas de là...



j'avais eu ce problème, et il me semble bien qu'en faisant (après avoir supprimé ce fichier...)

cd /etc/init.d

./mysqld restart



ça avait remarché...

In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Bon mon problème est le suivant à présent :



Mysql fonctionne sous Apache2, mais impossible d'accèder à mon serveur. Voilà les logs :



[Thu Feb 23 02:00:18 2006] [warn] pid file /var/run/apache2.pid overwritten -- Unclean shutdown of previous Apache run?

[Thu Feb 23 02:00:18 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) configured -- resuming normal operations

[Thu Feb 23 02:00:18 2006] [alert] (11)Resource temporarily unavailable: apr_thread_create: unable to create worker thread

[Thu Feb 23 02:00:18 2006] [alert] (11)Resource temporarily unavailable: apr_thread_create: unable to create worker thread

[Thu Feb 23 02:00:29 2006] [alert] Child 20167 returned a Fatal error... Apache is exiting!




Mysql ne fonctionne pas sous Apache 1.3, en revanche, j'arrive à y accèder.



Que faut-il faire pour que Apache 2 fonctionne de nouveau ? (A savoir,
il fonctionnait tres bien avant l'installation de mysql.....)
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
Oui moi ça me l'avait fait parce que le fichier n'existait pas... J'ai du réinstaller MySQL :/



Bon, si ça marche toujours pas :

apt-get remove mysql-server

apt-get remove mysql-client

apt-get remove mysql-common



apt-get install mysql-server

apt-get install mysql-client

apt-get install mysql-common



(il doit en avoir en trop car quand on en install, ça installe les
autres... Il y en a aussi à l'installation qu'il doit falloire faire
des un autre ordre, je ne me rappelle plus de l'ordre).

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
Ben.. apparament apache s'est éteint de façon anormal (pas de shutdown
classic) donc le pid ne s'est pas éffacé. Essayes de le redémarrer.

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,


"Mysql ne fonctionne pas sous Apache 1.3, en revanche, j'arrive à y accèder."



??



ça ça ne veut rien dire...



c'est php qui appelle une extention nommée "php-mysql" qui qui se connecte à mysql... apache ne se connecte pas à mysql...



apt-get install php-mysql (si t'es en php4... sinon, vas dans dselect
ou dans le gestionnaire de paquets synaptique pour chercher le nom...)



Bon, et après ajoute :



extension=mysql.so



dans le fichier php.ini situé dans /etc/php/apache2


et vas dans : /etc/apache2/mods-enabled, vérifie que tu as php.conf
et php.load dedans, si ça n'est pas le cas, alors vas dans
/etc/apache2/mods-available, et copie les fichiers php.conf et php.load
vers /etc/apache2/mods-enabled...





si t'aimes pas les commandes cp, ou éditer avec vi, commence par faire :



apt-get install mc



et ensuite, fais tout avec mc...


In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
En général quand tu fais apt-get install php-mysql ça rajoute l'extention dans php.ini automatiquement.

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

"Mysql ne fonctionne pas sous Apache 1.3, en revanche, j'arrive à y accèder."

> Ce qui veut dire, Mysql ne fonctionne pas quand Apache 1.3 est
installé, mais Apache 1.3 fonctionne normalement ! (pas de problème
comme Apache 2)



LoadModule php4_module /usr/lib/apache/modules/libphp4.so

Lorsque j'ajoute le module php4, Apache 2 ne démarre plus du tout (le module existe pourtant).



J'ai déjà essayé de tout reinstallé, mysql, php, apache... rien n'y fais.



Je n'ai pas les fichier php.conf et php.load dans mods-enabled, ni dans mods-available.
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Starting web server: Apache2Syntax error on line 395 of /etc/apache2/apache2.conf:

Cannot load /usr/lib/apache/modules/libphp4.so into server:
/usr/lib/apache/modules/libphp4.so: cannot open shared object file: No
such file or directory
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Quand je prend le module de Apache 1.3 :



Starting web server: Apache2Syntax error on line 395 of /etc/apache2/apache2.conf:

Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib/apache/1.3/libphp4.so: undefined symbol: ap_block_alarms
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,

t'as quoi comme message d'erreur lorsque tu fais load module ?




à mon avis, ça vient du fait que là, t'as chargé dans apache2 un module apache...



LoadModule php4_module /usr/lib/apache/modules/libphp4.so



à la place de :



LoadModule php4_module /usr/lib/apache2/modules/libphp4.so

In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

Mince j'ai oublié de 2 pour apache 2, j'ai du coup la même erreur que pour apache 1.3...
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
Mouarf moi je te dis réinstalles toi ça ira plus vite parce que là c'est un gros sac de neux :/

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,

[auteurdetail.aspx?ID=257327 thomvaill], réinstaller est un réflèxe windowsien...

In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
171
Date d'inscription
samedi 4 décembre 2004
Statut
Membre
Dernière intervention
31 août 2009

J'ai déjà fais une reinstallation, mais ça ne fait rien !

Starting web server: Apache2Syntax error on line 395 of /etc/apache2/apache2.conf:

Cannot load /usr/lib/apache/1.3/libphp4.so into server: /usr/lib/apache/1.3/libphp4.so: undefined symbol: ap_block_alarms



> Y'a toujours cette erreur lorsqu'il load le module...
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
Salut,

t'as un module apache 1.3 avec un serveur apache2 évidement, ça bloque...

In a dream, I saw me, drop dead... U was there, U cried... It was just a dream, if I die, U won't cry, maybe, U'll be happy

Mon site (articles sur la programmation et programmes)
Messages postés
366
Date d'inscription
mercredi 7 avril 2004
Statut
Membre
Dernière intervention
20 février 2007
2
Ca ce voit tèlement que suis encore sous Windows ?

snif :'(



Bon si non, pour le module php pour apache2, c'est pas :

apt-get install libapache2-mod-php

?

Thomvaill
IRC : Thomas (irc.heliosnet.org:6667 #programmation)