Compatibilité Application C#

Résolu
Signaler
Messages postés
165
Date d'inscription
mercredi 8 octobre 2003
Statut
Membre
Dernière intervention
10 novembre 2008
-
Messages postés
6351
Date d'inscription
samedi 1 juin 2002
Statut
Modérateur
Dernière intervention
2 août 2014
-
Bonjour ,j'ai réalisé une applicatino avec MVS 2003 en C# et lorsque je
la donne a un copain qui n'a pas MVS sur son ordi il met un message
d'erreur au lancement de l'applicartion comme quoi elle arrive pas a
s'initialiser. Est-ce normal ? Y a t'il des DLL ou autre chose a
installer ? Qu'est ce que le Framwork ?



MErci

Bonne Prog

5 réponses

Messages postés
427
Date d'inscription
mercredi 1 octobre 2003
Statut
Membre
Dernière intervention
29 janvier 2008
1
petit historique ^^

La plateforme .Net est apparue apres windows XP => elle n'est pas implémentée en natif avec cet OS (ni les versions antérieurs).

Il faut donc que ton copain récupere le frameWork

http://www.microsoft.com/downloads/details.aspx?FamilyId=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=fr

toi tu l'a directement installé avec MVS 2003

@ quoi il sert ? : Le package redistribuable de Microsoft .NET Framework 2.0 installe le runtime .NET Framework et les fichiers associés requis pour l'exécution d'applications développées pour le .NET Framework 2.0.

Sinon au niveau des DLL si ton application fait appel à des référence n'oublie pas de lui passer :)

++ bonne journée
Messages postés
6351
Date d'inscription
samedi 1 juin 2002
Statut
Modérateur
Dernière intervention
2 août 2014
98
Salut,

Attention !
Si l'application est développée sous VS2003, et donc compilée pour le Framework 1.1, il vaut mieux que celui ci soit lui aussi installé sur la machine, ainsi l'application sera executée par le runtime 1.1, et non pas le 2.0.
Les différentes versions du Framework sont conçue pour cohabiter, alors autant en profiter, et éviter les problèmes de compatibilité éventuels :-)

.NET Framework 1.1
.NET Framework 1.1 Service Pack 1

/*
coq
MVP Visual C#
*/
Messages postés
165
Date d'inscription
mercredi 8 octobre 2003
Statut
Membre
Dernière intervention
10 novembre 2008

Merci beaucoup pour ces précision, je me coucherais mons bete ce soir.

Bonne Prog
Messages postés
165
Date d'inscription
mercredi 8 octobre 2003
Statut
Membre
Dernière intervention
10 novembre 2008

Pourquoi lorsque que je clique sur réponse accepter il est pas en vert apres la validation du message de mise engarde ?

Mrci

Bonne Prog
Messages postés
6351
Date d'inscription
samedi 1 juin 2002
Statut
Modérateur
Dernière intervention
2 août 2014
98
Oui apparemment il y a qq problèmes.
Essaie en ayant taper quelquechose dans la zone de saisie avant d'accepter la réponse pour voir.

/*
coq
MVP Visual C#
*/