Problème de connection.

Signaler
Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006
-
Messages postés
1
Date d'inscription
jeudi 28 septembre 2006
Statut
Membre
Dernière intervention
28 septembre 2006
-
Bonjour.

Voila j'avais une base de donnée sous une vielle version d'Access et cela se passait bien. Mais je l'ai migré vers une version Access 2000 et maintenant je n'ai plus de connexion vers ma base.
Voici le message d'erreur:

Microsoft OLE DB Provider for ODBC Driverserror '80004005'
[Microsoft][Gestionnaire de pilotes ODBC] Échec SQLSetConnectAttr du pilote

Si je comprends bien c'est une erreur du driver, moi j'ai juste celui la :

Driver do microsoft Access (*.mdb) 4.00.6304.00
Microsoft Access Driver (*mdb) 4.00.6304.00

Est-ce qu'il en faut un autre ?

Merci d'avance.

11 réponses

Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006

Bon, j'ai tous repris a zéro.
J'ai intallé ma base dans ODBC et donnée tous les droits en administrateur dans l'onglet sécurité de ma base et également dans iis, site web, propriété, répertoire de base.
Maintenant j'ai ce message la:


Erreur de compilation Microsoft VBScript error '800a0401'
Fin d'instruction attendue
/iisHelp/common/500-100.asp, line 11
Dim objASPError, blnErrorWritten, strServername, strServerIP, strRemoteIP Dim strMethod, lngPos, datNow, strQueryString, strURL
--------------------------------------------------------------------------^
Microsoft OLE DB Provider for ODBC Drivers error '80004005'
[Microsoft][Pilote ODBC Microsoft Access] Le moteur de la base de données Microsoft Jet ne peut pas ouvrir le fichier '(Inconnu)'. Il est déjà ouvert en mode exclusif par un autre utilisateur, ou vous devez avoir l'autorisation de visualiser ses données.
/micro/connexion.asp, line 21


Je n'y comprend plus rien ??????????
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Salut,

Tu es bien sûr que tu as les droits de lecture sur ta
base ? est ce que l'utilisateur windows nommé IUSR_TonServer à les
droits ??
(question débile : est ce que ta base est ouverte dans Access ? en effet celui ci l'ouvre en mode exclusif....)
Qu'est
ce que tu veux dire par "J'ai intallé ma base dans ODBC" ? (dans le
fournisseur de sources de données ODBC ? si oui, dans l'onglet
"système" ou dans l'onglet "utilisateur" ?)

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006

J'ai oublié de dire que c'est en local que j'ai c'est problème, je n'ai jamais encore essayé en ligne.
Tu es bien sûr que tu as les droits de lecture sur ta base ?
Oui, je pense. Lecture seule est décocher et en mode administrateur, j'ai donné tous les droits lecture, écriture de la base.

Est-ce que ta base est ouverte dans Access ? Non.

J'ai installé ma base dans ODBC dans l'onglet source de donnée système.
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Donc c'est tout bon normalement...

Une dernière vérification : dans l'explorateur windows, fait clique droit sur ta base, puis Propriétés, onglet Sécurité, là fait ajouter, tappe IUSR_LeNomDeTonPc er fait OK, puis regarde s'il a bien les droits qu'il lui faut
(je sais, j'insiste... mais presque toutes les erreurs de ce genre viennent plus ou moins de là...)

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006

Merci Nurgle.
Donc j'ai fait ce que tu m'as dit et cela a créé un compte invité internet.
La j'ai vérifié les droit et il n'y a que lecture et exécution de coché et lecture....
Normalement, il y aurrai du avoir aussi l'écriture de coché ????
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Désolé de répondre si tard
As-tu résolu le problème ?

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006

Pas grave, mais j'ai quand même reussi à résoudre le prob.
Comment j'en sais rien mais à force de recommençer, j'ai réussi à me connecter avec ma base.Dommage que je n'ai pas trouvé la raison.
Merci a +.
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
lol, dans ce cas mets-toi "Réponse Acceptée", pour dire que tu as résolu ton problème

A++

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
18
Date d'inscription
lundi 12 décembre 2005
Statut
Membre
Dernière intervention
10 mai 2006

Re bonjour.

Voila, mon problème est revenue, j'ai reformaté mon ordi et je n'arrive plus a me connecter à ma base de donnée.
Erreur de compilation Microsoft VBScript error '800a0401'

Fin d'instruction attendue

/iisHelp/common/500-100.asp, line 11

Dim objASPError, blnErrorWritten, strServername, strServerIP, strRemoteIP Dim strMethod, lngPos, datNow, strQueryString, strURL
--------------------------------------------------------------------------^

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][Pilote ODBC Microsoft Access] Le moteur de la base de données Microsoft Jet ne peut pas ouvrir le fichier '(Inconnu)'. Il est déjà ouvert en mode exclusif par un autre utilisateur, ou vous devez avoir l'autorisation de visualiser ses données.

/encadrement/connexion.asp, line 21

Donc j'ai repris tous les points que nurgle m'avait d'écris dans ce post, mais la je suis bloquer a ce niveau.
"Une dernière vérification : dans l'explorateur windows, fait clique droit sur ta base, puis Propriétés, onglet Sécurité, là fait ajouter, tappe IUSR_LeNomDeTonPc er fait OK, puis regarde s'il a bien les droits qu'il lui faut
(je sais, j'insiste... mais presque toutes les erreurs de ce genre viennent plus ou moins de là...)"

quand j'ajoute IUSR_LeNomDemonPc, il me le refuse et me marque dans une autre fenêtre: impossible de trouver le nom et il me propose de le corriger.
Le problème, c'est qu'il me le rajoute pas...

La, je ne sais plus quoi faire, je pete un cable.
Si quelqu'un à une idée...

Merci d'avance.
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Dans ce cas là, clique sur "Avancé..." dans la fenêtre où tu dois normalement tapper IUSR_... et là clique sur "Rechercher" :
Tu vas avoir en dessous la liste de tous les utilisateurs du PC, IUSR_QuelqueChose devrait y être .
Après tu n'as plus qu'à lui mettre les droits dont il a besoin :)
(si ça ne marche toujours pas, essaye de mettre les droits en écriture également, et si ça ne marche encore pas, essaye de mettre les droits pour tout le dossier qui contient la base...)

<hr size="2" width="100%">Nurgle (Antoine)
Messages postés
1
Date d'inscription
jeudi 28 septembre 2006
Statut
Membre
Dernière intervention
28 septembre 2006

En tout cas pour moi ca a marché
essaye de mettre IUSR_"nom" avec nom en majuscule c ptre ca.
Enfin bon merci de m'avoir aidé j'allais vraiment peter un cable donc merci bcp