Problème avec Devc++ et OpenGL et Glut

Résolu
Signaler
Messages postés
154
Date d'inscription
samedi 7 janvier 2006
Statut
Membre
Dernière intervention
28 septembre 2008
-
Messages postés
154
Date d'inscription
samedi 7 janvier 2006
Statut
Membre
Dernière intervention
28 septembre 2008
-
Bonjour, j'ai des petits problèmes avec la librairie glut.h et j'utilise dev c++.

en effet, en faisant quelques recherches sur le forum, j'ai trouvé ceci :
http://www.dil.univ-mrs.fr/~garreta/generique/autres/OGL/
mais cela ne m'avance pas tellement :

mon problème est : j'ai trouvé comme tutoriaux pour OpenGL en C ceux ci :
http://www.linuxgraphic.org/section3d/openGL/

et quand j'essaie de compiler les fichiers sources de leurs tutoriaux (disponibles ici : http://www.linuxgraphic.org/section3d/openGL/ressources/didac1.tgz)

et bien dev c++ me retourne de nombreux messages d'erreur tels :
[Linker error] undefined reference to [mailto:`glFinish@0' `glFinish@0']
[Linker error] undefined reference to [mailto:`wglSwapBuffers@4' `wglSwapBuffers@4']
[Linker error] undefined reference to [mailto:`wglGetCurrentContext@0' `wglGetCurrentContext@0']

...

J'ai téléchargé le package glut.h grâce au gestionnaire de packages de devc++

Que dois-je faire pour résoudre ces problèmes ?

Merci d'avance de votre aide

4 réponses

Messages postés
154
Date d'inscription
samedi 7 janvier 2006
Statut
Membre
Dernière intervention
28 septembre 2008

Merci, ca marche !
Messages postés
2023
Date d'inscription
mardi 24 septembre 2002
Statut
Membre
Dernière intervention
28 juillet 2008
5
Dans l'éditeur de lien, mets ca:

-lglut32

-lopengl32

-lglu32

-lgdi32

-lwinmm
Messages postés
755
Date d'inscription
samedi 15 mai 2004
Statut
Membre
Dernière intervention
30 janvier 2011

j'alai le dire :)
si tu est sous VC++ #pragma comment(lib,"ta lib.lib");
Messages postés
2023
Date d'inscription
mardi 24 septembre 2002
Statut
Membre
Dernière intervention
28 juillet 2008
5
Il est sous devC++, donc pas de pragma.