Erreur retourné par le SGBD

Signaler
Messages postés
6
Date d'inscription
mardi 14 décembre 2004
Statut
Membre
Dernière intervention
7 février 2006
-
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
-
Bonjour à tous, j'ai un petit problème, l'écriture ds la bd se fait, mais j'ai un msg d'erreur -->

insert into TabTest values ('TOTO','TITI',99)
ADODB.Recordset error '800a0e78'

Operation is not allowed when the object is closed.

/wform/FinTransaction.asp, line 10

>Comme vous pouvez constater j'ai une table de 3 champs (un varchar, un varchar et un number) (oracle)
Merci pour tout aide, c tout con, mais je butte vmt sur çà
/*******************/
/*FICHIER INSERTION*/
/*******************/


insertion dans la table "tabtest"












/*********************/
/*FICHIER FinTransaction*/
/*********************/

3 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
Salut,

Est ce que ton objet "conn" est bien ouvert ?

De plus, pour réaliser un INSERT, tu n'as pas besoin d'utiliser un RecordSet, tu peux faire tout simplement un conn.Execute(StrSQL).

Nurgle
Messages postés
6
Date d'inscription
mardi 14 décembre 2004
Statut
Membre
Dernière intervention
7 février 2006

Merci je n'y avais pas pensé ;) pr le conn.execute. Mais l'erreur reste tjs, j'ai tester la propriétée ".state" qui indique l'état de l'objet ado (ouvert ou fermé) le resultat est ..bizarre !
=>

<%
StrSQL="insert into TabTest values ('"& Ucase(Request("nom"))& "'," & "'"_
& Ucase(Request("prenom"))& "',"_
& Request("num")&")"
response.write StrSql&"
"
response.write rec.state&"
"'affiche 0 c normal je l'ai pas encore ouvert
rec.open StrSQL, conn
response.write rec.state'affiche 0, alors que je viens de l'ouvrir ???!!!
'rec.open StrSQL, conn
conn.Execute(StrSQL)'Merci pour le conn.execute, nurgle ;)
'rec.close
conn.close
%>
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
c'est bizarre que ton RecordSet ne veuille pas s'ouvrir...

Mais si je comprends bien le Conn.Execute fonctionne ?
(dans ce cas, un petit "Réponse Acceptée" ?)

Nurgle