Question sur WebBrowser avec le FW 2.0

Résolu
cs_shaneT Messages postés 2 Date d'inscription mardi 13 janvier 2004 Statut Membre Dernière intervention 4 février 2006 - 4 févr. 2006 à 12:47
cs_shaneT Messages postés 2 Date d'inscription mardi 13 janvier 2004 Statut Membre Dernière intervention 4 février 2006 - 4 févr. 2006 à 14:09
Bonjour,

Je développe actuellement une application qui doit récupérer des données sur internet, pour ensuite les traiter.
Pour récupérer la page j'utilise le code suivant :

web.Navigate(mon_url); //web est un WebBrowser
do { System.Windows.Forms.Application.DoEvents(); }
while (web.ReadyState != WebBrowserReadyState.Complete);

Avec certaines pages, une "Erreur de script de Internet Explorer" apparait et force l'utilisateur à choisir si oui ou non il veut continuer à éxécuter le script de cette page... rapidement génant quand il faut le faire 2000 fois, à 15s d'intervalle :x
erreur : "document.getElementById(...) a la valeur Null ou n'est pas un objet"
J'aimerai savoir comment on peut répondre à la place de l'utilisateur, ou désactiver ce 'warning', le site n'étant pas modifiable...

Merci d'avance

2 réponses

cs_coq Messages postés 6350 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 101
4 févr. 2006 à 13:06
Salut,

Probablement via la propriété ScriptErrorsSuppressed.

/*
coq
MVP Visual C#
*/
3
cs_shaneT Messages postés 2 Date d'inscription mardi 13 janvier 2004 Statut Membre Dernière intervention 4 février 2006
4 févr. 2006 à 14:09
Wow... j'ai eut beau passer en revue les propriétés du WebBrowser, je n'ai pas tilté devant celle là

Merci beaucoup coq
0
Rejoignez-nous