Configuration php.ini pour mail

dam_37 Messages postés 32 Date d'inscription jeudi 2 février 2006 Statut Membre Dernière intervention 27 février 2006 - 3 févr. 2006 à 14:22
malalam Messages postés 10839 Date d'inscription lundi 24 février 2003 Statut Membre Dernière intervention 2 mars 2010 - 3 févr. 2006 à 16:15
Avis à tous ceux qui savent,
Malgré le nombre important d'infos sur l'envoi de mail, j'ai toujours le même problème:
Ma fonction mail est correcte mais le pb vient du php.ini
je sais pas comment le configurer, le pgm que je développe est pour une entreprise mais pour être mis sur le web, seulement pour la boite en local et donc je n'ai pas de provider et je ne sais pas quoi mettre dans SMTP.
Le msg affiché est:
mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()

Peut-être que je me plante et tant que je n'ai pas de provider je ne pourrais envoyer de mail mais il doit bien y avoir une soluce.
J'attends vos idées les génies, merci d'avance...

4 réponses

malalam Messages postés 10839 Date d'inscription lundi 24 février 2003 Statut Membre Dernière intervention 2 mars 2010 25
3 févr. 2006 à 14:50
Hello,
il te faut un serveur de mail, d'une manière ou d'une autre. Puis renseigner ton php.ini avec les bonnes valeurs.
Vous envoyez bien des mails, à votre boîte...?
0
dam_37 Messages postés 32 Date d'inscription jeudi 2 février 2006 Statut Membre Dernière intervention 27 février 2006
3 févr. 2006 à 15:08
oui et justement j'ai tenté de mettre SMTP le localhost de la boîte mais ça ne doit pas etre ça...
il existe des serveurs mails justement sur le net. j'en ai installé un qui s'appelle ArGosoft Mail Server et il m'indique ça quand je le lance:

Quand je teste à nouveau ma fonction, j'obtiens ceci:
Warning: mail(): SMTP server response: 551 User not local.
0
dam_37 Messages postés 32 Date d'inscription jeudi 2 février 2006 Statut Membre Dernière intervention 27 février 2006
3 févr. 2006 à 16:08
Enfait voila le contenu de l'image:

03/02/2006 14:59:49 - SMTP Server started. Listening on port 25


03/02/2006 14:59:49 - POP3 Server started. Listening on port 110


03/02/2006 14:59:49 - Finger Server started. Listening on port 79


03/02/2006 14:59:49 - Error starting Web server: [10048] Address already in use


Message size limit 5 MB


Winsock version: $0101


High version: $0202


Description: WinSock 2.0


System status: Running


Maximum sockets: 32767


Local host: SCYFRPC002


Local addresses: 163.157.137.157


Local host after reverse lookup: SCYFRPC002.corp.skf.net


03/02/2006 15:02:10 - Requested SMTP connection from 127.0.0.1


03/02/2006 15:02:10 - ( 1) 220 ArGoSoft Mail Server Freeware, Version 1.8 (1.8.8.4)


03/02/2006 15:02:10 - ( 1) HELO SCYFRPC002


03/02/2006 15:02:10 - ( 1) 250 Welcome [127.0.0.1], pleased to meet you


03/02/2006 15:02:10 - ( 1) MAIL FROM:<me@localhost.com>


03/02/2006 15:02:10 - ( 1) 250 Sender "me@localhost.com" OK...


03/02/2006 15:02:10 - ( 1) RCPT TO:<damien.chaum@hotmail.fr>


03/02/2006 15:02:10 - ( 1) 551 User not local. We don't relay


03/02/2006 15:02:10 - ( 1) QUIT


03/02/2006 15:02:10 - ( 1) 221 Aba he


03/02/2006 15:02:10 - SMTP connection with 127.0.0.1 ended. ID=1
0
malalam Messages postés 10839 Date d'inscription lundi 24 février 2003 Statut Membre Dernière intervention 2 mars 2010 25
3 févr. 2006 à 16:15
T'as pas plutôt un administrateur du serveur mail, dans ta boîte, a qui tu peux demander les paramètres...?
0