Lancement application via Process.Start [Résolu]

Signaler
Messages postés
193
Date d'inscription
jeudi 4 décembre 2003
Statut
Membre
Dernière intervention
12 août 2010
-
Messages postés
193
Date d'inscription
jeudi 4 décembre 2003
Statut
Membre
Dernière intervention
12 août 2010
-
Bonjour.
J'ai remarqué une chose en utilisant Process.Start dans une application, j'essaye de lancer un programme (Epsxe pour ceux qui connaissent) via mon application .net. Mon soucis est que en lancant epsxe de cette facon, il ne trouve plus certains de ses fichiers de config. Personnellement je pense que cette bizarrerie est peut etre due au fait qu'on ne demarre pas le prog à partir de son dossier d'origine (genre dans un raccourci il y a le champ 'Démarrer dans').
Je ne sais pas si mes supposition son exactes mais si quelqu'un sais comment indiquer à Process.Start de démarrer le prog à partir de son dossier ou si vous avez deja eu un probleme semblable, je suis tres interessé ^^
Merci d'avance.

3 réponses

Messages postés
3246
Date d'inscription
lundi 25 avril 2005
Statut
Modérateur
Dernière intervention
27 octobre 2012
33
Salut, as tu regardé la propriété ProcessStartInfo.WorkingDirectory.
Messages postés
193
Date d'inscription
jeudi 4 décembre 2003
Statut
Membre
Dernière intervention
12 août 2010

Je ne connaissais pas. Mais ca à l'air de correspondre à ce que je cherche. Je fais un essai des que je rentre chez moi à midi :)
Merci.
Messages postés
193
Date d'inscription
jeudi 4 décembre 2003
Statut
Membre
Dernière intervention
12 août 2010

Bon bah essai plus que concluant :)
A l'aide du WorkingDirectory l'appli fonctionne normalement.
Merci encore.