Ftp avec localhost [Résolu]

xavdk 11 Messages postés jeudi 23 janvier 2003Date d'inscription 6 février 2006 Dernière intervention - 31 janv. 2006 à 17:32 - Dernière réponse : xavdk 11 Messages postés jeudi 23 janvier 2003Date d'inscription 6 février 2006 Dernière intervention
- 5 févr. 2006 à 20:38
Bonjour à tous,
ma question est vraiment simple:
Pourquoi le bout de code suivant ne marche pas en local (avec easyPhp1-8 Apache etc...)
alors que avec mon hébergeur distant c'est ok .
Je précise que localhost semble reconnu car on a le message "Impossible de ..."
seulement après un time-out de 30" 1 minute et on voit le message "en attente de localhost " au bas de l'écran.

merci d'avance à mon sauveur !

<?php
$ftp_server="localhost";
$ftp_user_name="*****";
$ftp_user_pass="****";


// Test de la ressource


$conn_id = ftp_connect($ftp_server) or die("Impossible de se connecter à $ftp_server en FTP");
// Authentification avec nom de compte et mot de passe
$login_result = ftp_login($conn_id, "$ftp_user_name", "$ftp_user_pass");


// Vérification de la connexion
if ((!$conn_id) || (!$login_result))


{ die ("Echec dans Tentative de connexion FTP à $ftp_server avec $ftp_user_name"); }


else {
echo "Connecté à $ftp_server, avec $ftp_user_name ";
}
?>
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
cs_Anthomicro 9440 Messages postés mardi 9 octobre 2001Date d'inscription 13 avril 2007 Dernière intervention - 31 janv. 2006 à 17:57
3
Merci
Salut,

il faut que tu installes un serveur FTP. et si tu souhaites te connecter à distance sur ton serveur ftp en local bah il faut que le port 21 soit ouvert ;-)

Merci cs_Anthomicro 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de cs_Anthomicro
Meilleure réponse
supergyver 29 Messages postés jeudi 19 février 2004Date d'inscription 14 février 2007 Dernière intervention - 31 janv. 2006 à 18:08
3
Merci
Il y a de grandes chances que ton erruer vienne du fait que tu n'aies pas de serveur FTP installé comme l'indique Anthomicro.

Voilà un petit lien pour un serveur FTP minimaliste mais simple à configurer:



http://www.clubic.com/telecharger-fiche10300-ftp-server.html

Merci supergyver 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de supergyver
Meilleure réponse
xavdk 11 Messages postés jeudi 23 janvier 2003Date d'inscription 6 février 2006 Dernière intervention - 1 févr. 2006 à 12:25
3
Merci
Merci à vous 2 mais je rame toujours autant!
J'ai installé le serveur TYPSoft comme indiqué par Supergyver , il est en route mais tjs le même pb : la phase de ftp_connect ne marche pas !
Quelle est la bonne valeur de $ftp_server ?


J'ai tout essayé : localhost ; 127.0.0.1 ; ftp://localhost ; etc ...
C'est pareil en précisant le port 21ftp://localhost%20comment/ dans la connect

Merci d'éclairer ma lanterne

Merci xavdk 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de xavdk
Meilleure réponse
xavdk 11 Messages postés jeudi 23 janvier 2003Date d'inscription 6 février 2006 Dernière intervention - 5 févr. 2006 à 20:38
3
Merci
J'ai du me planté!
En fait Localhost ou 127.0.0.1 font l'affaire ...

Merci xavdk 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de xavdk

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.