Petit problème de texture ! Sans doute très simple ;-)

Résolu
darkein666
Messages postés
2
Date d'inscription
samedi 14 janvier 2006
Statut
Membre
Dernière intervention
23 janvier 2006
- 21 janv. 2006 à 20:17
darkein666
Messages postés
2
Date d'inscription
samedi 14 janvier 2006
Statut
Membre
Dernière intervention
23 janvier 2006
- 23 janv. 2006 à 08:34
Bonjour tout le monde,

J'ai un code qui marche niquel sous Jcréator mais qui ne m'affiche rien quand je l'ouvre directement en htm la solution doit être toute simple mais je suis bloqué dessus depuis 2 jours, j'ai cherché sur le web, dans les cours et les forums et je ne trouve rien donc je me permet de poster cette question . Voici mon code :

import java.awt.*;
import java.applet.*;
import javax.swing.*;
import java.awt.image.*;
import java.awt.geom.*;

public class Texture extends Applet {

public void paint(Graphics g)
{
Graphics2D g2d = (Graphics2D) g;

ImageIcon MaTexture = new ImageIcon("MaTexture.jpg");

BufferedImage bufferedImage = new BufferedImage(MaTexture.getIconWidth(), MaTexture.getIconHeight(), BufferedImage.TYPE_INT_RGB);

Graphics2D g2d2 = bufferedImage.createGraphics();

g2d2.drawImage(MaTexture.getImage(), 0, 0, this);

Shape imageRect = new Rectangle2D.Double(0.0, 0.0, bufferedImage.getWidth(), bufferedImage.getHeight());

TexturePaint imagePaint1 = new TexturePaint(bufferedImage, imageRect.getBounds2D());

g2d.setPaint(imagePaint1);

g.fillRect(100,100,100,100);

}

}

Merci d'avance

2 réponses

cs_darkduck
Messages postés
138
Date d'inscription
vendredi 28 février 2003
Statut
Membre
Dernière intervention
29 février 2008

22 janv. 2006 à 00:05
Salut,



Tu as du te tromper de forum, ici c'est pour le Flash.

Essaye sur ce site : http://www.javafr.com/



@+ Sans rancune
3
darkein666
Messages postés
2
Date d'inscription
samedi 14 janvier 2006
Statut
Membre
Dernière intervention
23 janvier 2006

23 janv. 2006 à 08:34
Merci pour le renseignement !
De toute manière j'ai trouvé le problème, la prochaine promis je me tromperai pas de forum
@+
0