Problème d'affichage d'HEADERS avec mail();

[Résolu]
Signaler
Messages postés
67
Date d'inscription
samedi 10 septembre 2005
Statut
Membre
Dernière intervention
8 juillet 2008
-
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
-
Bonjour à tous !

j'utilise la fonction mail() pour envoyer un mail au format HTML. Je suis allé sur le site officiel de PHP pour voir comment s'écrivaient exactement les HEADERS et spécialement le "FROM". Mon site est hébergé chez ONLINE.

J'ai donc un $headers = "From: NOM_DE_MON_SITE"."\n";
car je veux pas d'adresse mail qui s'affiche. Mais quand je reçois le mail, j'ai : NOM_DE_MON_SITE@php1-j.online.net

Et j'ai essayé avec une adresse email valide et ça me donne quand même:
ADRESSE_EMAIL@DOMAINE@php1-j.online.net

Ma question est : est-ce que ça vient de mon code ou du serveur ou d'ailleurs ? Si c'est mon code, pouvez-vous m'aider ?

Merci

JeanMi66

3 réponses

Messages postés
2350
Date d'inscription
mercredi 13 octobre 2004
Statut
Membre
Dernière intervention
18 avril 2015
3
Du serveur. C'est lui qui se charge de rajouter ce qu'il manque :)
Messages postés
67
Date d'inscription
samedi 10 septembre 2005
Statut
Membre
Dernière intervention
8 juillet 2008

Merci, je vais voir avec lui.

JeanMi66
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
9
Salut,

Juste un conseil au passage, oublie ONLINE, t'as mieux pour aussi cher voire moins ailleurs ;-)

a +

<hr size="2" width="100%"><li>Entraide, dépannage et vulgarisation informatique : Mon site de vulgarisation informatique</li><li>Codes-php.net</li>