Easyphp et mail()

[Résolu]
Signaler
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
-
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
-
Bonjour... ou bonsoir ;)



Je code un site en locale pour ensuite le mettre en ligne une fois terminé.J'utilise easyphp pour cela.

J'ai un probleme avec la fonction mail car easyphp n'as pas de serveur smtp intgré.

j'ai donc regard dans le php.ini et j'ai trouvé un endroi pour renseigner le smtp.

youhou super!!!! sauf que..... quand je me connect via outlook, il me
faut bien un mot de passe ... comment faire donc car dans le php.init
il n'y a pas de variable smtp_password!!!





[mail function]

; For Win32 only.

SMTP = smtp.tiscali.fr

smtp_port = 25



; For Win32 only.

;sendmail_from = me@example.com



; For Unix only. You may supply arguments as well (default: "sendmail -t -i").

;sendmail_path =

4 réponses

Messages postés
861
Date d'inscription
mardi 26 mars 2002
Statut
Membre
Dernière intervention
29 novembre 2006
1
Sael og blesuð



La configuration que vous avez faites est la bonne si vous êtes chez
tiscali ... Il n'y a rien de plus à faire ... Pour mémoire : smtp envoi
de courrier et pop réception de courrier donc identification ... ce qui
n'est pas nécessaire pour l'envoi d'où l'absence de variables telles
que smtp_password ou smtp_login...



Pour être clair il n'y a besoin de s'authentifier que pour recevoir du mail ( pop, pop3, imap) et non pas pour en envoyer ( smtp ) ...



Eventuellement une chose à faire :



; For Win32 only.

sendmail_from = votre_mail@votre_fai.ltd



Cela fera votre reply ... Mais bon c'est pas forcément utile ... ;-)



Autre chose en passant : préférez wamp à easyphp ... ;-) => http://www.wampserver.com Mais cela reste un avis tout personnel ... Cependant vous aurez accès à apache2 et php5 ... ;-)



Bon courage ...


NB : Si la réponse vous convient merci de l'accepter pour fermer ce thread ...



Sigurjón Bírgir Sigurðssón aka Sjón
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
2
je vien de trouver !!! ( desolé pour les multipost)

je vais expliqué ca peut toujour servir a d'autres !



pour easyphp il faut configurer le php.ini qui ce trouve dans le dossier /conf_file/ pour que ca marche..

et non pas avec celui qui ce trouve dans le repertoire /php/



voili voulou
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
2
merci beaucoup!
Messages postés
105
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
14 février 2013
2
en fait j'ai changé dans le php.ini mais :

Warning: mail(): Failed to connect to mailserver at "localhost"
port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in c:\program files\easyphp1-8\www\compny style\connect\inscription.php on line 79





on dirais bien que ca ne l'as pas pris en compte ...

peut etre qu'il y a d'autre php.init ! ?