Traitement d'image

[Résolu]
Signaler
Messages postés
39
Date d'inscription
jeudi 27 mai 2004
Statut
Membre
Dernière intervention
18 février 2008
-
Messages postés
39
Date d'inscription
jeudi 27 mai 2004
Statut
Membre
Dernière intervention
18 février 2008
-
HELP !!!!!!!

Bonjour, J'effectue des traitements d'image et y'a plusieurs trucs qui ne fonctionnent pas. L'historique :



Ce qui marche :

- je créé une image A

- je prend un morceau de B que je colle dans A

- j'enregistre A sur le serveur pour réutilisation

- j'affiche A et B dans des pages PHP





Ce qui ne marche pas : sur A, avant enregistrement sur le serveur, je veux coloriser des pixels. Et là RIEN NE MARCHE.

$palette=imagecreate(10,10);

$Couleur = imagecolorallocate($palette,255,0,0)



Méthode 1 : imagesetpixel($imagecible,$x_dep,$y_dep,$couleur) ne donne rien. Pas de pixel colorisé !

Méthode 2 : imagefilledrectangle($imagecible,$x_dep,$y_dep,$x_dep2,$y_dep2,$couleur) ne donne rien. Pas de rectangle colorisé !

Méthode 3 :
imagecopymerge($imagesource,$couleur,$x_dep,$y_dep,1,1,2,2,100) ou
imagecopy($imagesource,$couleur,$x_dep,$y_dep,1,1,2,2) ne donne rien
non plus en prennant $imagesource=fichier à la bonne couleur





Je pense qu'il doit y avoir un problème de définition des couleurs,
c'est pas possible autrement. Mais alors, comment définir une Put.. de
couleur ?




PekLandais

2 réponses

Messages postés
10839
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
25
Hello,

montre le code complet plutôt, on y verra plus clair sur les différentes ressources que tu utilises (parce qu'il y en a beaucoup là).
Messages postés
39
Date d'inscription
jeudi 27 mai 2004
Statut
Membre
Dernière intervention
18 février 2008
3
J'ai trouvé l'erreur, c'était un compteur en trop qui foutait la merde
dans le positionement de l'utilisation d''une des 3 méthodes..



Merci

PekLandais