Problème composant opendialog

Résolu
Signaler
Messages postés
6
Date d'inscription
dimanche 4 décembre 2005
Statut
Membre
Dernière intervention
29 décembre 2005
-
Messages postés
6
Date d'inscription
dimanche 4 décembre 2005
Statut
Membre
Dernière intervention
29 décembre 2005
-
Bonjour,

je souhaite utiliser le composant opendialog pour accéder à un fichier csv.

Malheureusement et je ne sais pas pour quelle raison le nom enregistré
dans la propriété Filename est incorrect..je récupère des caractères
spéciaux illisibles.

Je pensais que cela venait de ma version de delphi assez ancienne
(delphi 4 Pro) mais non..meme comportement sur mon poste avec la
version 2005.

Quelqu'un a t il une idée?? Cela viendrait il de ma version d'OS?? WIN XP HOME SP2.

Si quelqu'un a déjà rencontré ce problème merci de me le faire savoir. ;o)

2 réponses

Messages postés
198
Date d'inscription
mardi 6 août 2002
Statut
Membre
Dernière intervention
29 octobre 2008

Bizzard !!!

Voici un bout de code valide pour voir les différences !!!

Var
vFileResult : TOpenDialog;
begin
vFileResult := TSaveDialog.Create(nil);
Try
// Initialisation de la recherche
vFileResult.Filter := 'Fichiers Excel (*.xls)|*.xls';
// Execution de la recherche du fichier résultat
if vFileResult.Execute then
edFileSave.Text := vFileResult.FileName;
Finally
vFileResult.Free
End;

vaughan
Messages postés
6
Date d'inscription
dimanche 4 décembre 2005
Statut
Membre
Dernière intervention
29 décembre 2005

Sa fonctionne...bizarre en effet..

Merci