Erreur de syntaxe INSERT INTO [Résolu]

Signaler
Messages postés
45
Date d'inscription
dimanche 29 mai 2005
Statut
Membre
Dernière intervention
14 avril 2011
-
Messages postés
45
Date d'inscription
dimanche 29 mai 2005
Statut
Membre
Dernière intervention
14 avril 2011
-
Salut

J'ai une erreur de syntaxe dans la requette suivante, et je n'arrive pas à comprendre pourquoi

INSERT INTO arcVersement (service, agentID, dateVersement, dateDebut,
dateFin, conservation, desc, nbPieces, versement) VALUES ('RH',
'xxxxxxxx', #12/05/2005#, #12/31/1999#, #1/1/2000#, 'I', 'hfdghdfh',
666, 5)

Sachant que service, agentID et conservation sont de type texte ; dateVersement, dateDebut, dateFin sont de type date / heure ; nbPieces, versement sont de type numériques et desc est de type mémo

Je travaille avec une base access, j'ai essayé de mettre les dates entre apostrophes, sans apostrophes, et pareil pour le 666 et le 5... j'ai fais toutes les combinaisons possibles et je touve pas...

Merci d'avance à celui qui me comuniquera la solution

3 réponses

Messages postés
698
Date d'inscription
jeudi 16 janvier 2003
Statut
Membre
Dernière intervention
20 mai 2011
2
salut

DESC est un mot clef sous SQL
exemple SELECT ... ORDER BY monChamps DESC
pour indiquer de classer par ordre descroissant.

c'est pourquoi ca plante (a ce propose, pense a mettre le meesage d'erreur la prochaine fois, ca pourra nous aider a t'aider ;))

tu as donc deux solutions :


1 - tu change le nom de ce champs, ce qui est a mon sens la meilleure solution, car appeler un champs ou une table par un mot clef SQL , c'est source d'ennuis par la suite.


2 - si tu as deja trop de choses qui tournent comme ca et que tu ne peux plus changer le nom de ce champs, tu "dis" explicitement a Access que c'est un champs et nom le mot clef. je crois que tu dois pouvoir mettre des crochets : [DESC] au de DESC, mais je ne suis pas tout a fait sur de cette notation sous ACCESS.


(si ca ne marche pas, essaie de mettre entre guillements, ou qq chose comme ca)


en tout cas le probleme doit venir de la !
Messages postés
45
Date d'inscription
dimanche 29 mai 2005
Statut
Membre
Dernière intervention
14 avril 2011

Bon j'avance...

Après avoir testé la requette par petit bout (entendez "je commence par n'ajouter que le service, puis si ca marche j'ajoute l'agentID...") je suis arrivé à la conclusion suivante...

desc ne peut pas être rempli (c'est le seul champ mémo). Y a il un code particulier pour remplir cette colone ? Merci d'avance (et désolé pour la dérive de sujet, vu que maintenant, c'est un problème d'access )
Messages postés
45
Date d'inscription
dimanche 29 mai 2005
Statut
Membre
Dernière intervention
14 avril 2011

Merci, j'avais trouvé, j'ai eu un flash et j'ai oublié de répondre

du coup, j'ai mis "description" et ca marche beaucoup mieux (j'ai passé l'après midi là dessus)