Touche fleche haut bas

Signaler
Messages postés
77
Date d'inscription
lundi 17 octobre 2005
Statut
Membre
Dernière intervention
4 septembre 2008
-
Messages postés
77
Date d'inscription
lundi 17 octobre 2005
Statut
Membre
Dernière intervention
4 septembre 2008
-
Bonjour,
J'ai une fiche avec des boutons. Dans certaines conditions, certains boutons sont visibles ou invisible ou inaccessible. Mon problème est le suivant. avec la touche TAB, le focus se déplace de bouton en bouton dans l'ordre que j'ai défini. ça marche. Mais lorsque j'utilise les flèches du clavier (haut bas droite et gauche) le focus se déplace aussi de bouton en bouton mais à un moment le focus disparait. Je ne sais pas où il se trouve, peut être sur un bouton que j'ai rendu invisible sur la fiche. Y a t-il un moyen de régler ce problème? c'est à dire que l'appuie sur les flèches, ai la même fonction que la touche TAB ou à défaut y a t-il un moyen de neutraliser les touches flèches?

Merci

3 réponses

Messages postés
4202
Date d'inscription
samedi 16 octobre 2004
Statut
Modérateur
Dernière intervention
13 juin 2020
37
desactive le Enable des elements invisible...


en clair :

with button1 do begin

visible := false;

enable := false;

end;
______________________________________________
try
WhiteNight := Gloup(Kawa);
exept
on GloupOverFlow do GoToWaterClosed;
end;
Messages postés
4202
Date d'inscription
samedi 16 octobre 2004
Statut
Modérateur
Dernière intervention
13 juin 2020
37
tu peu egalement te faire une fonction simple :







function SwapState (SwObj : TObject);

begin

with (SwObj as TButton) do begin

visible := NOT visible;

enabled := visible;

end;

end;

______________________________________________
try
WhiteNight := Gloup(Kawa);
exept
on GloupOverFlow do GoToWaterClosed;
end;
Messages postés
77
Date d'inscription
lundi 17 octobre 2005
Statut
Membre
Dernière intervention
4 septembre 2008

merci de ton aide, tes conseils m'ont dirigés vers la solution.
En fait les éléments invisibles qu'il soit enable ou non ne change rien. C'était en fait les 3 panels que j'avais sur ma fiche. En les mettant tous à enable=false, le déplacement avec les flèches est correct. Je pensais que les flèches fonctionnaient comme la touche Tab qui elle ne permet pas de mettre le focus sur les panels.