Problème d'affichage dans crystal reports

sdess Messages postés 18 Date d'inscription mardi 1 juin 2004 Statut Membre Dernière intervention 15 avril 2010 - 21 nov. 2005 à 13:41
jabbour0000 Messages postés 10 Date d'inscription dimanche 11 février 2007 Statut Membre Dernière intervention 14 juillet 2010 - 22 avril 2009 à 14:41
Bonjour,

Pour un projet en C# sous visual studio .net 2003, j'utilise Crystal reports pour faire les rapports. Cela fonctionne quasiement bien, sauf que j'ai un problème à l'affichage et à l'impression de la première ligne de tous mes champs.

Après analyse, j'ai le sentiment qu'il y a un décalage vers le haut du texte contenue dans la zone de texte, quelque soit le texte que je met. Y compris dans les zones nons modifiables de sous totaux par exemple. La zone est à l'endroit que j'ai indiqué dans le modeleur, mais le rendu du texte est décalé vers le haut de à peu près la motier de la hauteur du texte de la première ligne.

Quand je fais des exports en PDF, il n'y a pas ce problème, c'est uniquement dans les apperçus et à l'imression.

Est-ce que quelqu'un a une idée sur comment résoudre ce problème. Il m'en faut absoluement une car je vais devoir livrer l'appli au client, et dans ces conditions, ce n'ai pas exploitable ....

Merci d'avance pour votre aide.

3 réponses

jabbour0000 Messages postés 10 Date d'inscription dimanche 11 février 2007 Statut Membre Dernière intervention 14 juillet 2010
21 avril 2009 à 18:31
0
sdess Messages postés 18 Date d'inscription mardi 1 juin 2004 Statut Membre Dernière intervention 15 avril 2010
22 avril 2009 à 11:49
Bonjour,

Je t'avoue que depuis 2005, je n'ai plus de problème, mais je ne me souviens plus comment je l'ai résolu. J'ai eu tellement de problème avec Crystal Report que j'ai abandonné cet outils au profit de ITextSharp pour nos nouveaux projets.

Cela dit, le projet que j'évoquai en 2005 est toujours opérationnel avec CR. Je peux te dire quand même que nous avons abandonné la version de CR livré avec VS2003, au profit de la version XI. C'est peut-être cela qui avait corrigé ce problème.

Désolé de ne pouvoir t'aider plus.

Cordialement,

Steeve
0
jabbour0000 Messages postés 10 Date d'inscription dimanche 11 février 2007 Statut Membre Dernière intervention 14 juillet 2010
22 avril 2009 à 14:41
Merci beaucoup pour la réponse comeme.
je vais essayer ITextSharp malgrer que la premiere fois que je vois cette outils
merci beaucoup monsieur steeve
a+
0
Rejoignez-nous