Transmission d'une variable d'un SWF vers 1 script PHP, et problème lien email s [Résolu]

Signaler
Messages postés
67
Date d'inscription
samedi 10 septembre 2005
Statut
Membre
Dernière intervention
8 juillet 2008
-
Messages postés
1575
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
21 février 2011
-
Bonjour,



1- lorsque je clique sur un clip de ma page HTML contenant un SWF, une
page PHP se charge et attend une variable qui est sensé être transmise
depuis la page précédente qui est le SWF. Sur ce clip, j'ai tapé le
code suivant:



onClipEvent (mouseDown)

{

getURL("mapage.php?var=toto","_parent");

}


C'est sensé marcher ce truc je pense !? Pourtant le résultat est le
suivant: la bonne page se charge dans la bonne fenêtre du navigateur
mais une seconde fenêtre s'ouvre et me dit que l'url spécifié est
introuvable sur le serveur: http://www.monsite.fr/undefined



C'est quoi ce blème ?



2- J'ai un texte statique sur lequel je veux faire un lien pour envoyer
un mail (du style mailto, en HTML). Dans le champ "lien URL" du texte
statique, j'ai bien tapé les 2 emails séparés par un point-virgule,
mais ça marche pas ! Pourquoi ?



Merciiiiiiii !


JeanMi66

2 réponses

Messages postés
1575
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
21 février 2011
2
Salut



non mais au lieu d'utiliser la notation mouseDown, fait une action release :

sur le scenario contenant le clip (et non sur le clip) met :

nomOccurenceClip.onRelease = function(){

getURL("mapage.php?var=toto","_parent");

}

ca archera p'etre mieux car il me semle qu'un autre gars a eu ton prob, et avec cette methode ca marché



pour ton mail, ben faut mettre mailto devant !

mailto:toto@tata.com;tata@toto.com

++

Flash sans Limites
_Benjy chez kOlapsis

merci de penser a accepter
Messages postés
67
Date d'inscription
samedi 10 septembre 2005
Statut
Membre
Dernière intervention
8 juillet 2008

J'ai oublié de spécifier: ce clip est constitué lui même d'un autre
clip et d'un boutton. Moi, le GETURL est sur le clip principal.
Peut-être faut-il le mettre sur le clip qui le constitu ou le boutton ?



Merci.

JeanMi66