Problème affichage requete SQL dans DBGrid [Résolu]

Messages postés
3
Date d'inscription
lundi 23 février 2004
Dernière intervention
15 octobre 2005
- 13 oct. 2005 à 17:40 - Dernière réponse :
Messages postés
3
Date d'inscription
lundi 23 février 2004
Dernière intervention
15 octobre 2005
- 15 oct. 2005 à 02:02
Bonjour,
J'ai une requete SQL basée sur plusieurs champs de plusieurs tables (avec jointures). Je travaille sur une base Access et avec l'objet ADOQuery.
Cette requete fonctionne tres bien sous Acces mais dans mon DBGrid cela m'affiche seulement 3 champs sur les 4 que comprend ma requete. Ces 3 champs (ceux qui s'affichent) proviennent de la meme table alors que le 4eme provient d'une autre table. Je ne comprends pas.
Merci de votre aide.
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
4580
Date d'inscription
samedi 19 janvier 2002
Dernière intervention
9 janvier 2013
- 15 oct. 2005 à 00:32
3
Merci
Comment pourrait-on t'aider si tu n'indiques pas ta requête SQL ?

As-tu essayé de double cliquer sur ton composant TDbGrid pour vérifier que tu n'as pas oublié d'afficher un champ ?

Merci cs_Delphiprog 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de cs_Delphiprog
Messages postés
3
Date d'inscription
lundi 23 février 2004
Dernière intervention
15 octobre 2005
- 15 oct. 2005 à 02:02
0
Merci
C'est bon mon problème est résolu. C'étais juste une erreur dans le composant TADOQuery qui provoquait cette erreur d'affichage.
Merci quand meme.
Commenter la réponse de San35

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.