Colonne DataGrid

Résolu
Sinsitrus
Messages postés
855
Date d'inscription
samedi 11 juin 2005
Statut
Membre
Dernière intervention
21 août 2015
- 12 oct. 2005 à 18:54
sacdemerde
Messages postés
14
Date d'inscription
jeudi 6 octobre 2005
Statut
Membre
Dernière intervention
19 octobre 2005
- 14 oct. 2005 à 14:35
Salut !!
C'est vraiment important et j'ai passé sur tt vbfrance mais j'ai pas trouvé comment on peu, après avoir extrait les données dans un DataGrid (depuis un DataEnvironnement basé sur access) supprimer les colonnes indésirables.
Il paraît que c'est un code a faire, mais j'y arrive pas. S'il vous plaît aidez moi !!!

3 réponses

crn_c21
Messages postés
302
Date d'inscription
samedi 24 janvier 2004
Statut
Membre
Dernière intervention
4 février 2011

13 oct. 2005 à 23:07
Je sais pas si ca pourra t'aider mais tu peux definir le largeur de la colonne interressée à 0!
3
sacdemerde
Messages postés
14
Date d'inscription
jeudi 6 octobre 2005
Statut
Membre
Dernière intervention
19 octobre 2005

14 oct. 2005 à 14:33
Bon je sais pas si ca va t aider.
Déjà je pense que tu dois être sous VB6 parce que sous VB.net il suffit juste de passer la colonne visible a false avant le databind.

Madatagrid.columns(index).visible=false

Si j ai bien compris tu génère ta datagrid à partir d'un dataset gràce à un dataadapter créé à partir de access.
Il est possible de régénérer la commande select de ton dataadapter, afin que ton dataset ne contiennent plus les colonnes que tu veux dégager.
Dans cette optique ça donnerai un truc du genre

'en globale
Dim connectionstring
As
String = "tachaine de connection"

Dim Connexion
As
New SqlConnection(connectionstring)


'en locale

Connexion.open()

Dim data
As
New DataSet

Dim ma_commande
As
String = "machaine de connection"

Dim adapter
As
New SqlDataAdapter(ma_commande, connexion)
adapter.Fill(data)
DataGrid1.DataSource = data

connexion.Close()

J'espère que ça t'aidera :)
3
sacdemerde
Messages postés
14
Date d'inscription
jeudi 6 octobre 2005
Statut
Membre
Dernière intervention
19 octobre 2005

14 oct. 2005 à 14:35
Oups petit bug dans ma_commande faut que tu mette la commande SQL du style "SELECT ...." bien sûr sans les mauvaises colonnes.
3