Probleme d'étiquette et de Goto

Résolu
Guizmo95 Messages postés 28 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 2 novembre 2006 - 4 oct. 2005 à 12:53
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 - 11 janv. 2014 à 18:32
Bonjour,
Voilà mon problème est le suivant je rentre ce code :

Private Sub Drive1_Change()
On Error GoTo etiquette
Dir1.Path = Drive1.Drive
End Sub


etiquette:
MsgBox "erreur"
End Sub

Et j'obtient l'erreur suivante : "Erreur de compilation : Etiquette non définie"...
Je ne voi pas du tout pourquoi j'ai cette erreur alors que j'ai bien defini mon etiquette...
Merci de votre réponse
A voir également:

4 réponses

NHenry Messages postés 15032 Date d'inscription vendredi 14 mars 2003 Statut Modérateur Dernière intervention 26 janvier 2023 156
4 oct. 2005 à 13:02
Private Sub Drive1_Change()

On Error GoTo etiquette

Dir1.Path = Drive1.Drive

Exit Sub

etiquette:

MsgBox "erreur"

End Sub






Il est plus facile de batiser kk1 que de la convertir. (surtout en programmation)

Une question se pose sur le forum, pas en privé


NH
3
j ene vois pas de difference dans les codes
1
Guizmo95 Messages postés 28 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 2 novembre 2006
4 oct. 2005 à 13:08
Merci bcp pour ton aide NHenry !!!!!!
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 223
Modifié par ucfoutu le 11/01/2014 à 18:41
pas bonjour à toi non plus, donc.
Tu ne la vois vraiment pas ? ? ? ?
Tu l'aurais vue en au moins essayant ... (encore qu'elle saute littéralement aux yeux et que l'erreur de Guizmo95 était E N O R M E , même de la part d'un débutant de chez débutant ... )

________________________
Réponse exacte ? => "REPONSE ACCEPTEE" facilitera les recherches.
Pas d'aide en ligne installée ? => ne comptez pas sur moi pour simplement répéter son contenu. Je n'interviend
-4
Rejoignez-nous