Démarrage [Résolu]

bousfiha 47 Messages postés lundi 23 mai 2005Date d'inscription 1 novembre 2007 Dernière intervention - 7 sept. 2005 à 13:56 - Dernière réponse : aogie 108 Messages postés vendredi 11 juillet 2003Date d'inscription 27 novembre 2007 Dernière intervention
- 7 sept. 2005 à 14:04
bonjour, voilà c mon premier projet c#net, et j ai un un petit problème: quand j'execute l'application, j'ai le message d'erreur suivant: votre programme ne possède pas de point d'entrée défini. s'il vous plait que faire?
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
aogie 108 Messages postés vendredi 11 juillet 2003Date d'inscription 27 novembre 2007 Dernière intervention - 7 sept. 2005 à 14:04
3
Merci
Bonjour,



Il faut créer un Main dans ta classe principale (de type Form pour mon exemple) :

[STAThread]

static void Main()

{

Application.Run(new <TaClasse>);

}

-- AOGie --

Merci aogie 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de aogie
sebmafate 4947 Messages postés lundi 17 février 2003Date d'inscription 14 février 2014 Dernière intervention - 7 sept. 2005 à 14:04
0
Merci
qu'utilises-tu comme éditeur ?



normalement, Visual Studio et SharpDevelop mettre le point d'entrée automatiquement.



Voici un exemple :

[STAThread]

static void Main() {

Application.Run(new Form1());

}


Sébastien FERRAND
Commenter la réponse de sebmafate

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.