Bug avec un mshflexgrid

Signaler
Messages postés
2
Date d'inscription
mercredi 13 mars 2002
Statut
Membre
Dernière intervention
5 septembre 2005
-
Messages postés
2
Date d'inscription
mercredi 13 mars 2002
Statut
Membre
Dernière intervention
5 septembre 2005
-
Salut,



J'ai un souci avec mon mshflexgrid: je lance une requête, je rafraîchi
ensuite le contrôle data qui met à jour automatiquement le mshflexgrid
mais ensuite lorsque je sélectionne une ligne sur le contrôle mshflex,
c'est la ligne supérieure qui est sélectionnée.

La propriété Datasource de mon mshflex est adoNum.



'***** Execute la requête de recherche des numéros de la liste sélectionné *****

SQL_NUM = "SELECT DISTINCT " & _


"`PLC_OBJ`.NUM, `PLC_OBJ`.NAME, `TYPE`.M_TEXT " & _


"FROM `PLC_OBJ` INNER JOIN `TYPE` ON `PLC_OBJ`.TYPE = `TYPE`.TYPE "
& _


"WHERE (`PLC_OBJ`.CMODULE = " & dataModule.BoundText & ") AND
(`PLC_OBJ`.CAPI = " & dataAPI.BoundText & ")" & _


" AND ((`TYPE`.M_TEXT LIKE '" & Replace(txtFiltre.Text, "*", "%")
& "') OR " & _


"(`PLC_OBJ`.NAME LIKE '" & Replace(txtFiltre.Text, "*", "%") &
"') OR " & _


"(`PLC_OBJ`.NUM LIKE """ & Replace(txtFiltre.Text, "*", "%") &
"""))"



'***** Execute la requête et retourne les numéros correspondant *****

adoNum.RecordSource = SQL_NUM

adoNum.Refresh


Si quelqu'un connaît le souci, j'ai déjà lu quelque part que c'était un bug du mshflexgrid... ou un bug de mon côté???

Merci

1 réponse

Messages postés
2
Date d'inscription
mercredi 13 mars 2002
Statut
Membre
Dernière intervention
5 septembre 2005

En fait, mon mshflexgrid est lié à un datacombo. Lorsque je sélectionne
un élément dans la datacombo et que la requête me renvoi des données,
le mshflexgrid se comporte correctement. Mais dès que le recordset
renvoyé ne comporte aucune donnée, le mshflexgrid se décale et ne se
positionne plus corretement même si le recordset d'une nouvelle
sélection comporte des données.