Service windows et mysql

Signaler
Messages postés
63
Date d'inscription
jeudi 30 septembre 2004
Statut
Membre
Dernière intervention
18 juillet 2008
-
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
-
Bonjour,
Je ne parviens pas lors du démarrage d'un service windows à écrire dans une table mysql. je fais cela en asp.net.
"La référence d'objet n'est pas définie à une instance d'un objet."
Pourquoi?

Merci
GREG

5 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
22
Je ne comprend pas ce que tu veux faire !

T'aurais pas un bout de code ? le service windows c'est toi qui l'a écrit ?

sinon l'erreur que tu as veut dire, que tu fais appell a un objet avant de l'instancier c'est à dire avant de faire un new


<HR>
Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
Messages postés
63
Date d'inscription
jeudi 30 septembre 2004
Statut
Membre
Dernière intervention
18 juillet 2008

J'ai plus d'info...
Dans MON service (que j'ai donc tenté de faire), j'ai un function qui ajout des infos dans une table (mysql).
Quand je fais :
Dim connectionString As String = ConfigurationSettings.AppSettings("ChaineConnection")
ca plante.
Mais quand je fais :
Dim connectionString As String = "DataBase=intranet; ...."
ca marche
Donc c'est la récupération du paramêtre qui fonctionne pas.
Je sais pas pourquoi...
J'ai :
Service1.vb
crawling.exe.config
et mon service s'appel "crawling"

voila
Merci de ton aide. :-)
Greg
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
22
normal, quand tu fais ConfigurationSettings.AppSettings tu appelles un param-tre contenu dans le web.config et pour un service windows il n'y en a pas :)

je sais pas comment faire sinon, mais va plutot sur vbfrance.com ou csharpfr.com car la ca n'a plus vraiment de rapport avec asp ;)


<HR>
Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
Messages postés
63
Date d'inscription
jeudi 30 septembre 2004
Statut
Membre
Dernière intervention
18 juillet 2008

t'es sur que ca n'existe pas ...?
va voir ...
http://www.dotnet-tech.com/tutoriels/service-windows/

au point 3.

Merci quand meme
:-)
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
22
oui mais la c'est pas le web.config mais un autre fichier ;)

Mais je pensais pas qu'on y accedait de cette facon :p

Bref, il y a toujours des choses à apprendre ;)


<HR>
Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr