Problème avec la fonction file() [Résolu]

Signaler
Messages postés
37
Date d'inscription
vendredi 10 septembre 2004
Statut
Membre
Dernière intervention
21 avril 2007
-
Messages postés
3
Date d'inscription
mercredi 18 septembre 2013
Statut
Membre
Dernière intervention
23 janvier 2014
-
Salut, jai un problème qui m'embette en php, jai cette partie de code :

$url = "http://finance.yahoo.com/d/quotes.csv?s=GOOG&f=sl1d1t1c1ohgv&e=.csv";
$test = file($url);


$fcontents = join( '', $test );

Quand je lessai sur mon windows avec easyphp sa foncitonne et mon programme peut continuer. Mais dès que je le place sur mon serveur linux la fonction file() me renvoie une erreur :

Warning : file(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /usr/local/apache2/htdocs/virtuelbourse/yahoo.php on line 7

Et bien sur ceci fait que pu rien ne fonctionne donc la fonction join() renvoie cette erreur :
Warning: file(http://finance.yahoo.com/d/quotes.csv?s =GOOG&f=sl1d1t1c1ohgv&e=.csv): failed to open stream: Resource temporarily unavailable in /usr/local/apache2/htdocs/virtuelbourse/yahoo.php on line 7

Quest qui ne fonctionne pas et comment puis-je fixer ce problème? Merci

2 réponses

Messages postés
1662
Date d'inscription
lundi 16 septembre 2002
Statut
Membre
Dernière intervention
30 juillet 2008
1
Je ne l'avais jamais vu celle la... C'est une erreur de configuration coté serveur linux...

Regarde fais une recherche de ton erreur sur google avec l'option site:php.net

J'ai trouvé ceci :

http://bugs.php.net/bug.php?id=11058

La conversation devient interessante juste le message avant le 4 avril et ce qui suit.

Quoi qu'il en soit, le bug est considéré comme "bogus" donc c'est un problème de ton serveur.

, EssayezTestez avant de Poser une question !
http://www.lookstrike.com
Messages postés
3
Date d'inscription
mercredi 18 septembre 2013
Statut
Membre
Dernière intervention
23 janvier 2014

Bonjour,

essaye ce code dans le fichier php.in de ton serveur :

root@server[#] vi php.ini
allow_url_fopen = On
allow_url_include = On


ou celui la dans .htacces :

root@server[#] vi .htaccess
<IfModule mod_php5.c>
php_admin_value allow_url_fopen On
php_admin_value allow_url_include On
</IfModule>