à qui se fier?

marhoa Messages postés 41 Date d'inscription mercredi 20 juillet 2005 Statut Membre Dernière intervention 17 octobre 2006 - 29 juil. 2005 à 15:19
marhoa Messages postés 41 Date d'inscription mercredi 20 juillet 2005 Statut Membre Dernière intervention 17 octobre 2006 - 4 août 2005 à 12:03
Bonjour, je développe en asp.net sous WebMAtrix depuis 1 mois et j'aimerais savoir pourquoi les fonctions fournies par l'aide de VisualStudio ou du Framework 1.1 ne correspondent pas à celles utilisées par WebMatrix. En effet, je me retrouve souvent avec une erreur causée par une fonction récupérée dans des forume ou sur les sites d'aide Microsoft.
Y-a-t'il un moyen de mettre les Libraries de WebMatrix à jour afin d'avoir accès à toutes ces fonctions?

Merci.

6 réponses

cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
29 juil. 2005 à 19:49
Salut,

Que ce soit avec VS ou WebMatrix il s'agit du Framework 1.1
Peux tu donner un exemple d'erreur ?

Cocoricoooooooo !!!!
coq
MVP Visual C#
0
marhoa Messages postés 41 Date d'inscription mercredi 20 juillet 2005 Statut Membre Dernière intervention 17 octobre 2006
1 août 2005 à 11:43
Voici la dernière que j'ai eu:

TB_Description = RBL_MitelOrga.SelectedValue;

TB_Description est un Textbox et RBL_MitelOrga un RadioButtonList, j'ai trouvé la propriété "SelectedValue" dans la documation Framework SDK 1.1 installée sur mon PC mais le serveur me renvoie l'erreur suivante:

CS0117: 'System.Web.UI.WebControls.RadioButtonList' does not contain a definition for 'SelectedValue'

Ce n'est qu'un exemple, j'ai déjà eu plusieur fois ce genre d'erreurs sur des fonctions décrites dans MSDN, Framework ou des forums.

Dans l'explication de la propriété, on peut lire "Note: This namespace, class, or member is supported only in version 1.1 of the .NET Framework. "
Peut être que mon serveur ne supporte pas le Framework 1.1, je ne me rappelle plus des autres erreurs, je ne me rappelle pas si leurs déclaration comportaient cette phrase.

Salut et merci
0
cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
1 août 2005 à 19:17
Tu peux déterminer la version du Framework en utilisant Environment.Version.

Cocoricoooooooo !!!!
coq
MVP Visual C#
0
marhoa Messages postés 41 Date d'inscription mercredi 20 juillet 2005 Statut Membre Dernière intervention 17 octobre 2006
2 août 2005 à 09:26
Merci,
J'ai utilisé la fonction Environment.Version et voici mon numério de version :1.0.3705.288
Comment faire pour passer à la 1.1 . Surtout qu'elle est déjà installée sur mon PC. Est ce que le problèmle pourrait venir de la cohabitation entre Visual Studio et WebMatrix?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
benjiiim94 Messages postés 96 Date d'inscription vendredi 17 décembre 2004 Statut Membre Dernière intervention 13 juillet 2007
2 août 2005 à 17:13
Si la 1.1 est installé mais qu'elle ne fonctionne pas, il faut dire à IIS d'utiliser cette version et non plus la 1.0.

Pour cela, il y a un executable fourni avec le framework

Pour l'executer :

Ouvre une fenetre de commande (demarrer>executer>cmd)

et accède au dossier C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

puis execute aspnet_regiis.exe avec la commande -i (aspnet_regiis.exe -i)



++
0
marhoa Messages postés 41 Date d'inscription mercredi 20 juillet 2005 Statut Membre Dernière intervention 17 octobre 2006
4 août 2005 à 12:03
C'est sympa mais c'est le serveur de WebMatrix que je voudrais modifier, parceque sinon mon serveur IIS est à jour. J'ai regardé dans les menus de WebMatrix mais y'a rien, je sais pas où je pourrais trouver l'exe pour l'updater.

En tout cas merci de ton aide
0