%define

Signaler
Messages postés
161
Date d'inscription
samedi 25 juin 2005
Statut
Membre
Dernière intervention
1 août 2006
-
Messages postés
161
Date d'inscription
samedi 25 juin 2005
Statut
Membre
Dernière intervention
1 août 2006
-
salut !!

le compilateur de Visual C++ genere une erreur lorsque j'essaie d'utiliser la

directive %define . ça sera simpa si on m'aide à resoudre ce probleme .

merçi d'avance
A++

6 réponses

Messages postés
21041
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
30
#define AVEC un #

faut mettre cela sur cppfrance et non asmfr.

ciao...
BruNews, MVP VC++
Messages postés
161
Date d'inscription
samedi 25 juin 2005
Statut
Membre
Dernière intervention
1 août 2006

je veux pas faire la directive #define du C je voudrais utiliser celle de ASM

%define mais ça marche pas malheureusement ( d'ailleurs je savais la premiere)

A++
Messages postés
21041
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
30
sur MASM c'est "EQU":

macont EQU 120

ciao...
BruNews, MVP VC++
Messages postés
161
Date d'inscription
samedi 25 juin 2005
Statut
Membre
Dernière intervention
1 août 2006

merçi quand meme pour ton aide mais ça marche pas sous Visual C++ .

le compilateur me genere l'erreur suivante :
error C2400: inline assembler syntax error in 'opcode'; found 'EQU'

merçi d'avance

A++
Messages postés
21041
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
30
en asm inline de compilo C, faut definir tes constantes en C avant le bloc asm.

ciao...
BruNews, MVP VC++
Messages postés
161
Date d'inscription
samedi 25 juin 2005
Statut
Membre
Dernière intervention
1 août 2006

ok , merçi pour ton aide

A++