Erreurs de link. Besoin d'aide.

cs_Sunsawe Messages postés 64 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 5 avril 2007 - 20 juil. 2005 à 18:16
Alpacha Messages postés 95 Date d'inscription mardi 9 mars 2004 Statut Membre Dernière intervention 20 mars 2006 - 22 juil. 2005 à 22:39
Voilà je me heurte à ces erreurs de link à la compilation de ma librairie et google ne semble pas connaitre "std._Mutex.__dtor".



Linking...
LINK : warning LNK4075: ignoring '/EDITANDCONTINUE' due to '/INCREMENTAL:NO' specification
LINK : error LNK2020: unresolved token (0A00002B) std._Mutex.__dtor
LINK : fatal error LNK1120: 1 unresolved externals


Une idée?

6 réponses

imanedaoudi Messages postés 82 Date d'inscription vendredi 20 mai 2005 Statut Membre Dernière intervention 24 octobre 2005
20 juil. 2005 à 18:19
tu as oublier une bibliotheque peut etre, verifie les biblio que tu as utilisé
0
cs_Sunsawe Messages postés 64 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 5 avril 2007
20 juil. 2005 à 18:21
Oui j'ai supposé mais laquelle. Parce que j'ai n'ai besoin que d'une lib en plus de celle qu'ajoute automatiquement vc.net.

Alors comment savoir laquelle manque?

Je n'utilise rien d'exotique pourtant.
0
vecchio56 Messages postés 6535 Date d'inscription lundi 16 décembre 2002 Statut Membre Dernière intervention 22 août 2010 13
20 juil. 2005 à 19:10
Grace au nom: std._Mutex.__dtor
Moi je trouve ca plutot exotique
0
cs_Sunsawe Messages postés 64 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 5 avril 2007
20 juil. 2005 à 19:22
ouais mais ça, c'est pas moi qui m'en sert. à part les classes spécifiques à la lib que je n'ai pas oublié, j'utilise que des

std::string

std::stringstream

int

char*

et c'est tout. C'est quand même pas exotique ça non?


Et puis le code je le sors tel quel d'un projet qui fonctionne, je veux
juste en faire une lib. C'est peut-être lié à ça, y'a pas des trucs à
inclure par défaut pour ça?

Mais que google donne rien ça, ça m'inquiète sérieux.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_Sunsawe Messages postés 64 Date d'inscription mardi 21 juin 2005 Statut Membre Dernière intervention 5 avril 2007
21 juil. 2005 à 13:23
j'ai déterminé que l'erreur était du à l'utilisation des stringstream.

Mais je ne sais toujours pas comment arranger ça.
0
Alpacha Messages postés 95 Date d'inscription mardi 9 mars 2004 Statut Membre Dernière intervention 20 mars 2006
22 juil. 2005 à 22:39
Regarde la réponse dans le post concernant les stringstream, et dis moi le résultat
0
Rejoignez-nous