CFLDAP avec LDAP V3

Résolu
Signaler
Messages postés
45
Date d'inscription
dimanche 28 mars 2004
Statut
Membre
Dernière intervention
25 novembre 2005
-
Messages postés
45
Date d'inscription
dimanche 28 mars 2004
Statut
Membre
Dernière intervention
25 novembre 2005
-
Bonjour a tous & toutes, voila je bosse sur un requete LDAP car on a changé d' AD, on est passé en V3. Mais je sais pas si je m'y prend correctement car ca ne marche pas. Je bosse sous CF 5.0.

Ma requete :

<cfldap action="QUERY"
name="test"
username="MyName"
password="MyPassword"
server="192.168.61.154"
port="3268"
start="cn=users,ou=UTILISATEURS,ou=FRANCE,ou=PEPSI,ou=DOMAINE,dc=domaine,dc=org"
scope="subtree"
attributes="cn"></cfldap>

Et il me renvoie cette erreur :

<!--StartFragment -->
Error Diagnostic Information

CFLDAP


Invalid credentials

Donc soit je m'y prend comme un manche a coui..e soit y a un souci entre CF 5.0 et LDAP V3

Votre avis ?


---------------------------------------------------------------------------------
C'est curieux chez les marins ce besoin de faire des phrases...

2 réponses

Messages postés
45
Date d'inscription
dimanche 28 mars 2004
Statut
Membre
Dernière intervention
25 novembre 2005

Bonjour laurent, j'ai eu ma réponse par une autre personne, j'ai carrement zappé de la mettre sur le forum, désolé...
En faite ma requete était presque bonne. En faite le start ne doit pas commencer par un CN et le username doit être précédé par le domaine dans lequel l'objet CN de mon user se trouve.

Sylvain


----------------------------------------------------------------------------------
C'est curieux chez les marins ce besoin de faire des phrases...

http://www.evene.fr/citations/mot.php?mot=maladie
Messages postés
203
Date d'inscription
lundi 23 décembre 2002
Statut
Membre
Dernière intervention
11 mai 2006

Salut,

Il me semble que le serveur coldfusion utilise son propre nom d'utilisateur, a verifier dans les services.
Ensuite il te faut donner un access a cet utilisateur pour acceder a ton serveur LDAP.


Laurent