[J2me] Mon programme fait redémarrer le téléphone

keikomi Messages postés 2 Date d'inscription mardi 1 mars 2005 Statut Membre Dernière intervention 24 juillet 2005 - 15 juil. 2005 à 21:40
destructyom Messages postés 6 Date d'inscription lundi 23 mai 2005 Statut Membre Dernière intervention 11 décembre 2008 - 11 déc. 2008 à 09:36
Salut à tous,

J'ai développé une application dont l'objectif principal est de faire se détecter deux téléphones supportant le Bluetooth lorsqu'ils sont à portée l'un de l'autre, et de les faire afficher un message. Sur l'émulateur fourni par Sun (Wireless Toolkit), le programme fonctionne à la perfection. Mais lors des tests en vrai, qui ont été faits sur deux téléphones Nokia (6230 et 6230i), quand le client essaie de se connecter au serveur, parfois le client redémarre. Le téléphone s'éteint complètement, puis redémarre, mais sans demander le code PIN. Ca le fait de façon assez aléatoire (des fois ça fonctionne normalement). J'ai entendu parler de problèmes d'implémentation de la kvm sur les Nokia, est-ce que mon problème peut venir de là ? Quelqu'un a-t-il déjà eu ce problème ? Auriez-vous une solution à me suggérer ?
Merci !

Thibault

4 réponses

destructyom Messages postés 6 Date d'inscription lundi 23 mai 2005 Statut Membre Dernière intervention 11 décembre 2008
16 juil. 2005 à 16:11
Salut.

tu te sers de l'émulateur fourni par Sun (Wireless Toolkit), moi je
développe sur des mobiles Sony Ericsson, et je me sers du J2ME wireless
toolkit fourni par Sony Ericcssson, apparemant Nokia en fournit aussi,
sur cette adresse



http://www.forum.nokia.com/main/0,6566,033,00.html



voilà, bah j'espere que ça te sera utile
0
keikomi Messages postés 2 Date d'inscription mardi 1 mars 2005 Statut Membre Dernière intervention 24 juillet 2005
24 juil. 2005 à 17:37
Merci de ta réponse, effectivement l'émulateur Nokia reproduit le même problème donc ça va être plus facile à débugger dessus que directement en live sur les portables. Merci de ton aide !
0
crewe509 Messages postés 1 Date d'inscription mercredi 10 décembre 2008 Statut Membre Dernière intervention 10 décembre 2008
10 déc. 2008 à 18:40
ya know this is !!!!!!!!

puis-je savoir si ton logiciel s'appliques aux sony ericsson w660??
0
destructyom Messages postés 6 Date d'inscription lundi 23 mai 2005 Statut Membre Dernière intervention 11 décembre 2008
11 déc. 2008 à 09:36
Salut :)

Euh.... ça fait 4 ans maintenant que j'ai fait ce projet donc je peux rien te garantir (et puis youpi pour retrouver les sources dans mon bordel), mais si tu compiles le code avec le compilateur pour le Sony Ericsonn w660 ça devrait marcher je pense (si ce dernier existe). A l'époque on l'avait porté sur d'autres téléphones et ça marchait :)  Mais bon, en 4 ans les téléphones ont bien bien évolué.

++
0