Pb avec gltext

Résolu
vladisback Messages postés 61 Date d'inscription dimanche 19 novembre 2000 Statut Membre Dernière intervention 5 août 2008 - 15 juil. 2005 à 10:51
Alucards Messages postés 40 Date d'inscription mercredi 26 mars 2003 Statut Membre Dernière intervention 3 septembre 2008 - 3 oct. 2005 à 20:00
bonjour je cherche actuellement a afficher du text en openGl, il y a deja sur ce site un certain nombres de post et de sources la dessus, j'ai decidé d'utiliser gltext pour l'affichage (je ne veux pas utiliser de lib externe)
lorsque je n'affiche que du text aucun probleme. seulement si j'affiche des polygones texturé le text disparait. aprés quelque essai je me suis rendu compte que le text disparaisser lorsque j'ajouté "glEnable(GL_TEXTURE_2D);" dans mes initialisation d'opengl... comment faire? est ce que le probleme peut venir que le programme essai de mettre une texture au texte? et si oui comment enlever la texture sur celui ci? merci d'avance

2 réponses

KeniiyK Messages postés 326 Date d'inscription vendredi 13 août 2004 Statut Membre Dernière intervention 2 novembre 2007 2
18 juil. 2005 à 19:21
Désactive les textures avant d'afficher ton texte... glDisable(GL_TEXTURE_2D), si tu utilises l'éclairage de même...

KeniiyK
3
Alucards Messages postés 40 Date d'inscription mercredi 26 mars 2003 Statut Membre Dernière intervention 3 septembre 2008
3 oct. 2005 à 20:00
heu je pense qu'avant d'afficher ton teste tu devrais passer en mode 2D
y a une fonction qui le permet je me souviens plus laquelle bref
et une fois ton texte afficher tu repasse en mode 3d voila
0