Linker error avec dev cpp et la lib tiff

cs_misterpatate Messages postés 22 Date d'inscription mercredi 31 mars 2004 Statut Membre Dernière intervention 20 septembre 2006 - 11 juil. 2005 à 10:15
asmanur Messages postés 230 Date d'inscription mercredi 11 février 2004 Statut Membre Dernière intervention 4 août 2005 - 11 juil. 2005 à 11:53
Salut à tous,

Après plus d'un an et demi passé sur le java, je me remets péniblement
au c++ pour une application de traitement d'image. Bref, je travaille
sur dev cpp pour le moment car il ne me va pas trop mal, le soucis
c'est que j'ai des erreurs de link un poil chiante du style :





[Linker error] undefined reference to `TIFFOpen'

[Linker error] undefined reference to `TIFFGetField'

... (il y en a une bonne quinzaine...)



Je sais bien que ces fonctions doivent être implémentée dans la
libtiff.lib que j'ai, vu que je l'avais fait marcher (avant...). §J'ai
à peu près tout testé pour ce qui est d'inclure la dite librairie dans
le projet, inclure son répertoire dans les répertoires de lib et
d'include pour la compilation, mais rien n'y fait. Donc là, ça m'énerve
un peu.



Si quelqu'un pouvait m'aider SVP, je lui promets ma reconnaissance
éternelle d'une part et un coup de main ailleurs si je le peut.



@+











moi

5 réponses

cs_LordBob Messages postés 2865 Date d'inscription samedi 2 novembre 2002 Statut Membre Dernière intervention 11 mai 2009 10
11 juil. 2005 à 11:04
a premiere vu c'est parce que tu essai de compiler sans inclure les librairie de la bibliothèque. donc en fait lors de la compilation, le compilo ne trouve pas les fonction de la lib tiff.
en fait tu dois rajouter dans les propriété de ton projet lors de la génération d'inclure la librairie, il me semble que avec Dev-C++, il faut que tu fasses "-l" suivit du nom de la librairie. si le nom de la librairie est "libtiff" il faut alors mettre:
"-llibtiff"
Bob...

"La chance accorde ses faveur aux esprits avertis..."
0
cs_LordBob Messages postés 2865 Date d'inscription samedi 2 novembre 2002 Statut Membre Dernière intervention 11 mai 2009 10
11 juil. 2005 à 11:06
il te faudra aussi compiler la librairie "libtiff" avant de pouvoir l'utiliser !
Bob...

"La chance accorde ses faveur aux esprits avertis..."
0
cs_misterpatate Messages postés 22 Date d'inscription mercredi 31 mars 2004 Statut Membre Dernière intervention 20 septembre 2006
11 juil. 2005 à 11:29
Merci de ta réponse déjà...

Malheureseument le problème reste. Soit je mets le paramètre en
question au niveau de la compilation des différents fichiers et dans ce
cas même erreurs. Soit je le passe au niveau du linker et alors il me
dit qu'il ne trouve pas le fichier en question :



\Dev-Cpp\Bin\..\lib\gcc-lib\mingw32\3.2\..\..\..\..\mingw32\bin\ld.exe C:\Travail\Labo\progC++\er\C

cannot find -lressources/libtiff.lib



On remarque qu'il me bouffe un espace au passage -l"
"ressources/libtiff.lib. J'ai essayer de le mettre dans le même
répertoire mais ça ne change rien... Bref toujours en galère.



A propos de ta remqarque sur la compilation de la librairie tiff, elle
est en un fichier "libtiff.lib" qui a priori est déjà toute compilée et
prête à livrer sous emballage plastifiée et tout... ;o) Donc ça
devrait marcher en théorie, sauf si vraiment j'ai tout perdu de mes
connaissances en C++ et dans ce cas... tiens je ne sais pas ce que je
vais faire dans ce cas...



@+




moi
0
cs_misterpatate Messages postés 22 Date d'inscription mercredi 31 mars 2004 Statut Membre Dernière intervention 20 septembre 2006
11 juil. 2005 à 11:53
ça avance un peu...

J'ai plus ou moins réussit à inclure la lib, mais j'ai de nouveles erreurs :



Info C:\Travail\Labo\progC++\er\Info

resolving __iob by linking to __imp___iob (auto-import)



tif_win32.c C:\Travail\Labo\progC++\er\libtiff.lib(tif_win32.obj)(.text+0x444)

variable '_iob' can't be auto-imported. Please read the documentation for ld's --enable-auto-import for details.



tif_win32.c C:\Travail\Labo\progC++\er\libtiff.lib(tif_win32.obj)(.text+0x456)

variable '_iob' can't be auto-imported. Please read the documentation for ld's --enable-auto-import for details.



après c'est peut-être du à ma librairie...

moi
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
asmanur Messages postés 230 Date d'inscription mercredi 11 février 2004 Statut Membre Dernière intervention 4 août 2005
11 juil. 2005 à 11:53
essaye -ltiff le lib devant faut pas le mettre la plus part du temps
0