Comment determiner que le contenu d'une cellule est présent dans une colonne et

Résolu
Signaler
Messages postés
2
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
8 juillet 2005
-
Messages postés
2
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
8 juillet 2005
-
Bonjour,

Voici mon problème (sous VBA Excel 2000):
dans la cellule E2 je souhaite faire apparaitre un "O" quand le contenu de la valeur de la cellule A2 est présent dans la colonne A d'une autre feuille ("feuil1") et un N autrement.
le contenu des cellules est de l'alpha numérique en mode texte.

J'ai bien essayer avec la formule suivante maiss je n'arrive pas à comparer le contenu d'une cellule avec le contenu de la colonne:

ActiveCell.FormulaR1C1 = "=IF(RC[-4]='feuil1!R[1]C[-4],""O"",""N"")"

Merci de votre aide!

2 réponses

Messages postés
133
Date d'inscription
mardi 24 décembre 2002
Statut
Membre
Dernière intervention
8 juin 2012
4
Bonjour.


E2=SI(ESTNA(EQUIV(LC(-4);Feuil1!C(-4);0));"N";"O")

ctac
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 109 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
8 juillet 2005

Merci de ton aide,

Après avoir encore passer un peu de temps..... pas mal en fait, j'ai trouvé cette façon de faire également.

E2=SI(NB.SI('feuil1'!$A$3:$A$8000;A2)<>0;"O";"N")

Ca marche bien et je peut comparer du mode texte.

Merci encore et longue vie à ces Forums!!!

Bigfoxi