Problème AS et IIS avec dreamweaver

Signaler
Messages postés
2
Date d'inscription
vendredi 5 novembre 2004
Statut
Membre
Dernière intervention
5 juillet 2005
-
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
-
Bonjour,

Je commence à faire de l'asp avec dreamweaver et lors de ma toute première page (pas de bol), lorque que je mets les champs sur ma page et je je passe en mode dynamique pour visuliser ce que ça donne, hourra ca marche, les champs indiquent bien le contenu de la base! Sauf que si j'actualise, j'obtient ça comme erreur:

Erreur de compilation Microsoft VBScript error '800a0401'
Fin d'instruction attendue
/iisHelp/common/500-100.asp, line 11 Dim objASPError, blnErrorWritten, strServername, strServerIP, strRemoteIP Dim strMethod, lngPos, datNow, strQueryString, strURL
--------------------------------------------------------------------------^


Provider error '80004005'
Erreur non spécifiée
/aspe/page1.asp, line 5

Alors, j'attends un peu et je réactualise, et ça remarche... et ainsi de suite.

Quelqu'un peut il m'aider ?

Un grand merci

3 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Salut,



il faudrait nous dire ce qu'il y a dans "/aspe/page1.asp", ligne 5 !



Mais si c'est aléatoire (parfois ça marche, parfois ça marche pas...), le plus souvent c'est dû à des composants extérieurs

(comme les opérations sur des bases de données, ou d'autres trucs du genre...)


Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Messages postés
2
Date d'inscription
vendredi 5 novembre 2004
Statut
Membre
Dernière intervention
5 juillet 2005

Pour faire simple, voici la page entière

<http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Document sans titre</title>
<style type="text/css">
<!--
.Style1 {font-size: 36px}
-->
</style>
</head>



<%=(Recordset1.Fields.Item("Nom").Value)%>

<%=(Recordset1.Fields.Item("Prénom").Value)%>

&nbsp;

&nbsp;

</html>
<%
Recordset1.Close();
%>

J'ai fait une database avec 2 tables: une avec des noms et adresses et l'autre avec les codes postaux et les localités. Avec une realation entre les 2 tables. Rien de bien compliqué. Puis ensuite j'ai fait un quéry affichant l'entièreté des enrégistrements avec les codes postaux et les localités.

Merci de votre aide
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
au lieu de :

<%

var Recordset1 = Server.CreateObject("ADODB.Recordset");



Recordset1.ActiveConnection = MM_mesContacts_STRING;



Recordset1.Source = "SELECT * FROM contacts";

Recordset1.CursorType = 0;

Recordset1.CursorLocation = 2;

Recordset1.LockType = 1;

Recordset1.Open();

var Recordset1_numRows = 0;

%>

essai de mettre ça :

<% var RecordSet1 = Server.CreateObject("ADODB.RecordSet");

RecordSet1.CursorLocation = 2;

RecordSet1.Open("SELECT * FROM contacts", TaConnexion, 0,1);

var Recordset1_numRows = 0; %>

Je ne suis pas très familiarisé avec la syntaxe javascript , mais ça doit être un truc dans ce genre là...

(avec le "TaConnexion" qui est l'objet ADODB.Connexion que tu dû as créé avant...)



c'est une autre syntaxe qui est (normalement ) équivalente à la tienne. On sait jamais...






Nurgle
C'est une grande folie que de vouloir être sage tout seul !