Lecture d'un MP3 a partir d'un bouton qui est lui-même dans un clip...

Résolu
mathieuschmitt
Messages postés
2
Date d'inscription
dimanche 14 septembre 2003
Statut
Membre
Dernière intervention
3 juillet 2005
- 1 juil. 2005 à 14:23
mathieuschmitt
Messages postés
2
Date d'inscription
dimanche 14 septembre 2003
Statut
Membre
Dernière intervention
3 juillet 2005
- 3 juil. 2005 à 14:08
Salut, j'ai un petit souci qui me prends la tête:


Flash n'a aucune réaction quand je clic sur le bouton sensé envoyer le MP3 (ni un message d'erreur, ni rien...) Pourtant le code me semble bon, car le bouton en question fonctionne lorsqu'il est sur la "Sequence1", mais pas quand il est dans le clip... C'est quoi le truc?...


on (release){


var sound1 = newSound();
sound1.loadSound ("1.mp3", true); }

voilà...
Le pire c'est que je l'ai fait sur un autre site (qui fonctionne), mais quand j'importe le bouton qui fonctionne sur celui ci... il ne marche plus...
merci par avance

2 réponses

pegase31
Messages postés
6138
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
11
1 juil. 2005 à 15:09
Là, tu ne fais que charger ton son, pour jouer un son il faut faire :

MonSon.start();

Peg'
3
mathieuschmitt
Messages postés
2
Date d'inscription
dimanche 14 septembre 2003
Statut
Membre
Dernière intervention
3 juillet 2005

3 juil. 2005 à 14:08
oui, bien sur, ça c'est fait aussi, j'ai mis que la partie de code où je pensais qu'il pouvait y avoir un problème... Mais j'ai bien reglé le volume et les autres trucs, j'ai bien mis la fonction start, aucune erreur de code n'est detectée...
Par contre, quand je met ce clip dans un autre .fla, ca marche... mais pas sur le .fla actuel... ???


merci...
3