ASP.NET et ORACLE

Signaler
Messages postés
10
Date d'inscription
dimanche 1 septembre 2002
Statut
Membre
Dernière intervention
9 mai 2006
-
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
-
Erreur du serveur dans l'application '/WebApp3'.
<hr color="silver" size="1" width="100%">


Les composants client et réseau Oracle sont introuvables. Ces composants
sont fournis par Oracle Corporation dans l'installation client d'Oracle Version
7.3.3 (ou ultérieure). Vous ne pourrez pas utiliser ce fournisseur avant d'avoir
installé ces composants.
Description :
Une exception non gérée s'est produite au moment de l'exécution de la
demande Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur
l'erreur et son origine dans le code.

Détails de l'exception:
System.Data.OleDb.OleDbException: Les composants client et réseau Oracle
sont introuvables. Ces composants sont fournis par Oracle Corporation dans
l'installation client d'Oracle Version 7.3.3 (ou ultérieure). Vous ne pourrez
pas utiliser ce fournisseur avant d'avoir installé ces composants.



//******************************************



le probleme que les application window form se connecte avec la base
oracle et le application Web form génére des erreur de se type????

3 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
Eh bien...comme te le dis le message...tu dois installer les composants spécifiques à Oracle.



Je m'explique, pour te connecter à une base de données, tu as besoin
d'un pilote pour chaque type de base de données. Par défaut sont
installé les pilotes pour Access et SQLServer. Pour les autres DB, il
faut des composants fournis par le fournisseur de ta DB.



Pour ce qui est des applications WinForm et WebForm, ces deux sources
n'utilisent pas la même partie des Sources de Données (ODBC). Va voir
dans le Panneau de Configuration --> Outils d'Administration
--> Sources de Données --> Onglets "Pilotes ODBC" et vérifie que
le pilote est bien présent. S'il n'y est pas, tu dois l'installer à
partir du CD fourni avec Oracle ou alors télécharger l'install depuis
leur site web


Nurgle
C'est une grande folie que de vouloir être sage tout seul !
Messages postés
10
Date d'inscription
dimanche 1 septembre 2002
Statut
Membre
Dernière intervention
9 mai 2006

Merci mais mon probléme c'est pas ça ( car tout les pilotes sont installés)



pour moi j'ai trouvé la solution ds le site web suivant :



http://dotnetjunkies.com/WebLog/rtgurskevik/archive/2005/01/19/45958.aspx



la Solution est la suivante:






System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.


Problem
When
usign System.Data.OracleClient with Oracle9i client, i got the
following message while connecting to the Oracle database from and
ASP.NET application.


System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.



Cause
Security permissions were not properly
set when the Oracle 9i Release 2 client was installed on Windows with
NTFS. The result of this is that content of the ORACLE_HOME directory
is not visible to Authenticated Users on the machine; this again causes
an error while the System.Data.OracleClient is communicating with the
Oracle Connectivity software from an ASP.NET using Authenticated User
privileges.


Solution
To fix the problem you have to give the Authenticated Users group privilege to the Oracle Home directory.


<li>Log on to Windwos as a user with Administrator privileges. </li><li>Start Window Explorer and navigate to the ORACLE_HOME folder.</li><li>Choose properties on the ORACLE_HOME folder.</li><li>Click the “Security” tab of the “Properties” window.</li><li>Click on “Authenticated Users” item in the “Name” list.</li><li>Uncheck the “Read and Execute” box in the “Permissions” list under the “Allow” column.</li><li>Re-check the “Read and Execute” box under the “Allow” column</li><li>Click the “Advanced” button and in the “Permission Entries” verify
that “Authenticated Users” are listed with permission = “Read &
Execute”, and Apply To = “This folder, subfolders and files”. If not,
edit that line and make sure that “Apply To” drop-down box is set to
“This folder, subfolders and files”. This should already be set
properly but it is important that you verify it.</li><li>Click the “Ok” button until you close out all of the security
properties windows. The cursor may present the hour glass for a few
seconds as it applies the permissions you just changed to all
subfolders and files.</li><li>Reboot, to assure that the changes have taken effect.</li>
Try your application again.



posted on Wednesday, January 19, 2005 8:03 AM
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
Ah OK.

C'est sûr que je risquais pas de trouver ...

(le message d'erreur n'a rien à voir avec l'erreur elle-même...c'est plutôt rare )



Bon bah, tant que ça marche...

(tu peux mettre à ton propre post un "Réponse Acceptée"...)



@+++


Nurgle