Rss pb encodage avec php

Signaler
Messages postés
140
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
20 août 2012
-
Messages postés
140
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
20 août 2012
-
Hello,


Je suis en train de me mettre tout doucement au flux rss pour mon site en php : j'ai malheureusement des soucis...
probablement des problèmes d'encodage !!


j'ai mis cela comme entete


<?
Header("content-type: application/xml");
echo "<"."?xml version="1.0" encoding="ISO-8859-1"?".">
<rss version="2.0">";



mais dès que je tombe dans la partie
<description>bin xfg;sdfg</description>


c'est la cata !!


=> d'ou ma question : auriez vous des adresses de tutoriaux ou conseils pour moi ??


d'avance merci pour votre réponse, au plaisir de vous lire !!


H

4 réponses

Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
8
Salut,



commence par remplacer ton code par ça :



<?php
header('content-type: application/xml');
echo '<?xml version="1.0" encoding="ISO-8859-1"?>
<rss version="2.0">';


ensuite quel est ton problème ?


<hr size="2" width="100%">




<li>Entraide, dépannage et vulgarisation informatique: Mon site de vulgarisation informatique</li>
Messages postés
1106
Date d'inscription
samedi 8 novembre 2003
Statut
Membre
Dernière intervention
3 septembre 2006
21
http://www.phpcs.com/forum.v2.aspx?ID=495433

===========
Validez les réponses si ok...

ViewVite : HTML
Messages postés
140
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
20 août 2012

Merci pour vos réponses !
suis un peu au taff... je regarde azap et vous tient au courant... mais j'ai comme l'impression que mon pb va être réglé !!
;)

le temps n'épargne pas ce que l'ont fait sans lui.. le php non plus
Messages postés
140
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
20 août 2012

Hello,

De retour de vacances je me penche sur la question : fiou l'encodage est semble t-il bon -merci pour votre aide !- mais dès que je veux mettre un brin d'html... là ca ne va plus du tout !!
Je vous laisse regarder par vous même ;-(
(d'ailleurs si vous avez une bonne url pr valider des flux autre que http://feedvalidator.org/check.cgi je suis preneur : l'aide est trop minimaliste pour moi qui ne m'y connais pas trop)

au plaisir de lire votre prose !

H

<?
$message = 'ttttttttt é t';


//$message = addslashes($message);
//$message = htmlspecialchars($message);
$message = htmlentities($message);
//$message = 'tttttttttt';


?>
<title><?php print $message; ?></title>

ca me donne des erreurs du style


column 27: XML parsing error: :23:27: undefined entity
<title>ttttttttt [erreur ici] &lt;b&gt;&eacute;&lt;/b&gt; t</title>