Problème avec Mozilla

Signaler
Messages postés
87
Date d'inscription
lundi 22 avril 2002
Statut
Membre
Dernière intervention
12 octobre 2006
-
Messages postés
4936
Date d'inscription
lundi 17 février 2003
Statut
Modérateur
Dernière intervention
14 février 2014
-
Voilà, j'ai réalisé une application aspx
avec visual studio .net qui marche parfaitement avec Internet Explorer,
mais lorsque je le teste sous Mozilla Firefox (version 1.0.4) rien ne
marche.
J'ai une première page d'authentification avec login et
mot de passe, et lorsque je clique sur le bouton "ok" on dirait que le
code n'est pas exécuté.

Sous le bouton "ok", j'ai le code suivant (en c sharp):
XmlDocument xmlutilisateur = new XmlDocument();
xmlutilisateur.Load(ChemFicUtilisateurs);

string login = TxtLogin.Text;
string mpasse = TxtMPasse.Text;

XmlNode nd =
xmlutilisateur.SelectSingleNode("/Utilisateurs/Utilisateur[Login='"+login.ToLower()+"']");
if(nd !=null)
{


nd =
xmlutilisateur.SelectSingleNode("/Utilisateurs/Utilisateur[MotPasse='"+mpasse.ToLower()+"']");
if(nd != null)
{



FormsAuthentication.RedirectFromLoginPage(login+"¤"+mpasse, false);
}
else
{


LabErr.Text = "Login et/ou mot de
passe inconnu";
}
}
else
{
LabErr.Text = "Login et/ou mot de passe inconnu";
}

Es-ce que c'est "FormsAuthentication.RedirectFromLoginPage" que Mozilla n'aime pas????

Si quelqu'un pouvait m'aider ça serait vraiment bien.
merci d'avance

Aurélie

Aurélie

1 réponse

Messages postés
4936
Date d'inscription
lundi 17 février 2003
Statut
Modérateur
Dernière intervention
14 février 2014
37
tu devrais poser ta question sur le forum www.aspfr.com, je pense qu'elle aura plus de succes.

<hr>Sébastien FERRAND

Blog : http://blogs.developpeur.org/sebmafate