Chat socket ca rame

lawkz
Messages postés
2
Date d'inscription
mercredi 23 juin 2004
Statut
Membre
Dernière intervention
15 juin 2005
- 15 juin 2005 à 10:38
lawkz
Messages postés
2
Date d'inscription
mercredi 23 juin 2004
Statut
Membre
Dernière intervention
15 juin 2005
- 15 juin 2005 à 14:08
Bonjour,

j'ai un problème super bizar j'ai crée un chat (serveur et client) avec les composants socket de delphi 6.

Tout marche impec, sauf quant je test en réel (pas en local), là le
serveur est super long après debug je me rend compte que c'est à chaque
action sur une propriété du socket (ex: Socket.activeConnections).

J'aimerais apporter plus de précisions mais je n'en sais pas plus, alors si quelqu'un a une idée voir même une solution...

Merci



low

3 réponses

loicbernard
Messages postés
16
Date d'inscription
jeudi 22 mai 2003
Statut
Membre
Dernière intervention
15 juin 2005

15 juin 2005 à 11:52
Ben justement faudrait peut être plus de précision...
Comment est constitué le réseau(nombre de pc, bande passante, hub ?, switch?, )
bete question : mais le réseau est il lent pour d'autres applications? genre pour aller sur internet par exemple ou meme pour transférer un fichier via l'explorateur


Saurais-tu aussi donné les spécificationss des pc concernés (ram, vitesse cpu...) ?
0
loicbernard
Messages postés
16
Date d'inscription
jeudi 22 mai 2003
Statut
Membre
Dernière intervention
15 juin 2005

15 juin 2005 à 11:53
je sais pas pourquoi mais une fois sur 2 le forum me bouffe ma signature à l'envoi du msg...

amicalement

lolo
0
lawkz
Messages postés
2
Date d'inscription
mercredi 23 juin 2004
Statut
Membre
Dernière intervention
15 juin 2005

15 juin 2005 à 14:08
Non, rien à voir coté réseau je pense. Tout le
reste fonctionne parfaitement et même avec un cable croisé entre le
serveur et le client, ca rame...

Au niveau des pc il n'y a pas de problème rien en dessous de 1Gh avec 512Mo de ram.



low
0