Pb chiffre decimaux

Résolu
Signaler
Messages postés
177
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
21 avril 2010
-
Messages postés
177
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
21 avril 2010
-
bonjour,



voila, je suis sous oracle, jeffectue une requete qui me permet de recuperer des valuers numeriques comme 8,5 ou 10,5 etc....



ensuite je veu afficher ces valeurs ds mon interface delphi ds un
TDBText, je change le display format en mettant #,00, et la lorsque mon
query est execute et tou, il maffiche 8,00 ou 10,00 mai po les
8,5 ou 10,5 je compren vremen po



si kelkun peu maider merci

7 réponses

Messages postés
4297
Date d'inscription
samedi 19 janvier 2002
Statut
Modérateur
Dernière intervention
9 janvier 2013
31
Par défaut, la virgule est interprétée comme séparateur des milliers sur les versions françaises de Windows.
En remplaçant la chaine de formattage #,00 par #0.00 dans DisplayFormat tout devrait rentrer dans l'ordre.


<HR color=#008000>
Pensez à cliquer sur Réponse acceptée lorsque la réponse vous convient.
<
Messages postés
65
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
5 décembre 2005
1
je cherchair à laisser 2 chiffres après la virgule,
ça marche impec
Merci
Didier
Messages postés
177
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
21 avril 2010

dsl mai sa ne marche po chez moi en mettant #.00, en resultat jobtien tjrs mon chiffre 10.00 au lieu de 10.5



si vou avez une idee merci
Messages postés
4297
Date d'inscription
samedi 19 janvier 2002
Statut
Modérateur
Dernière intervention
9 janvier 2013
31
T103 : retire un "0" après le point et tu verras que ça va rentrer dans l'ordre.
Pense aussi à appuyer sur la touche F1 quand la propriété DisplayFormat est sélectionnée


<HR color=#008000>
Pensez à cliquer sur Réponse acceptée lorsque la réponse vous convient.
<
Messages postés
177
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
21 avril 2010

:s, jai fe ce ke vous mavez dit mai sa me fait tjrs la mem chose,



alor est ce ke sa vien des type des champs de ma base de donne oracle ? pourtant je leur ai mi number(2,2) , logiquement c bon

donc la je c vremen plu koi faire
Messages postés
4297
Date d'inscription
samedi 19 janvier 2002
Statut
Modérateur
Dernière intervention
9 janvier 2013
31
Puroiras tu prelar une lguane que tuot le mdone cempornd, le firaçans par epelmxe ?


<HR color=#008000>
Pensez à cliquer sur Réponse acceptée lorsque la réponse vous convient.
<
Messages postés
177
Date d'inscription
lundi 11 août 2003
Statut
Membre
Dernière intervention
21 avril 2010

oups, excusez moi



en faite quand je met #.0 dans displayformat, mon champs affiche par
exemple 10,0 au lieu de 10,5, alors que dans ma base de donnee oracle
si j'effectue la requete jobtiens bien 10,5 mais pas sous delphi