Pb avec form en asp.net, Vb, sur webmatrix

Signaler
Messages postés
3
Date d'inscription
mercredi 1 juin 2005
Statut
Membre
Dernière intervention
2 juin 2005
-
Messages postés
3
Date d'inscription
mercredi 1 juin 2005
Statut
Membre
Dernière intervention
2 juin 2005
-
Bonjour! J'ai un petit problème avec une petite tranche de code. Je suis débutant en asp.net et quelque chose semble bloquer mon bouton onclick. Quand je clique dessus rien ne ce passe, mais pourtant si il y a des erreurs dans le code du sub, ca m'envois l'erreur. C'est bizarre. Voici mon code:


<%@ Page Language="VB" %>


<%@ Register TagPrefix="uc0" TagName="_menu" Src="_menu.ascx" %>


<script runat="server">




Protected WithEvents btn As System.Web.UI.WebControls.Button


Sub BT_Send_Click(ByVal sender As Object, ByVal e As System.EventArgs)


Handles BT_Send.Click


LB_Message.Text = "La classe " & TB_Nom_classe.Text & " a correctement été créée !"


LB_Message.Visible = True




End Sub




</script>


<html>


<head>


</head>




<form>



----

,


</form>






<form runat="server">



----

,

----

Nom de la classe:,

,

----

Professeur principal:,

,

----

,


</form>




</html>

Merci beaucoup pour toute réponse, a+!

4 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
<%@ Page Language="VB" %>



<%@ Register TagPrefix="uc0" TagName="_menu" Src="_menu.ascx" %>



<script runat="server">



Sub BT_Send_Click(ByVal sender As Object, ByVal e As System.EventArgs)



LB_Message.Text = "La classe " & TB_Nom_classe.Text & " a correctement été créée !"



LB_Message.Visible = True






End Sub



</script>



<html>



<head>



</head>






<form>




<td colspan="2">



Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr
Messages postés
3
Date d'inscription
mercredi 1 juin 2005
Statut
Membre
Dernière intervention
2 juin 2005

Merci ton code est mieux écris, mais il semble que le code n'était pas mon problème. mon webmatrix est seulement incapable de gérer les demandes via le serveur, je l'es testé avec IIS sur localhost et ca fonctionne. Même avec ton code, sur webmatrix toujours rien. À moins que tu puisse m'aider avec webmatrix, je vais devoir aller sur leur site. merci a+
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
j'ai essayé pendant quelques heureuse webmatrix, et ca m'a suffit :p



Webmatrix n'est pas du tout adapté pour faire du web, en fait je me
demande meme à quoi il sert :o si ce n'est qu'il est gratuit et qu'on
peur faire deux trois bricoles :-/

Ce qui est bizarre c'est que ca marche sous IIS, cassini est bien lancé ?

<hr>Cyril - MCP ASP.net
Webmaster de : Hoshimi.CodeS-SourceS.fr<
Messages postés
3
Date d'inscription
mercredi 1 juin 2005
Statut
Membre
Dernière intervention
2 juin 2005

Il y a bien un petit icon de webmatrix server port 8080 dans mes icone en bas a droite. Je me demande si je dois sauvegarder mon travail qu'en même dans le root et la base de donner je la met ou? Dans le dossier de mon server sql ou dans le root aussi? Parce que même si je teste dans IIS la connection à la base de donné sql marche pas, c'est irritant, surtout que jai suivit toutes les procédure comme il le faut, même les paramètres à l'installasion, j'ai MSDE, IIS, framework 1.1, webmatrix bien sûr.

Ca me donne un erreur genre "null" n'est pas un utilisateur reconnu par trusted conection. Et j'ai aucune idé du id ou du pass que je dois utiliser, j'ai pas mal tout essayer. C'est stupid. Je peux linker ma bd à mon travail dans webmatrix, mais vu que le asp ne semble pas démarrer je peux même pas tester sous webmatrix. errrrrrrrrr