Au secours! recordset erreur 3001!! vba access!

cococorbac
Messages postés
1
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
13 mai 2005
- 13 mai 2005 à 17:29
x140
Messages postés
10
Date d'inscription
jeudi 6 février 2003
Statut
Membre
Dernière intervention
19 décembre 2007
- 21 nov. 2005 à 11:07
Bonjour à tous!!!

j'ai un soucis sous acces : je désire creer un recordset dans un formulaire indépendant. je tape le code suivante :

(déclarations)
Dim RsAQ As Recordset
Option Compare Database


private Sub Form_Activate()
Set RsAQ = CurrentDb.OpenRecordset("adhérents", dbOpendynaset)


End Sub

ceci genere une erreur 3001 : argument non valide.

j'ai essayé de remplacer dbopendynaset par dbopentable ou dbopenrecordsource c'est tjs la meme chose!
J'ai meme retiré l'argument et la virgule qui le précéde et là une autre erreur : argument manquant!

que puis-je faire?? ce code fonctionne sur une autre base! est-ce possible que ce soit les propriétés des bases qui poseraient probleme??

merci d'avance!!!
à bientôt!

2 réponses

AdilELHASSOUNI
Messages postés
145
Date d'inscription
vendredi 11 janvier 2002
Statut
Membre
Dernière intervention
19 juin 2007
1
13 mai 2005 à 21:39
Verifie Si sur les references de la base de donnees que DAO est avant ADO sinon soit tu doit changer la priorite soit declare ton recordset
Dim RsAQ As DAO.Recordset

bonne chance
0
x140
Messages postés
10
Date d'inscription
jeudi 6 février 2003
Statut
Membre
Dernière intervention
19 décembre 2007

21 nov. 2005 à 11:07
salut !

j'ai le meme probleme, donc j'aurais voulu savoir si t'avais trouvé une solution a ton probleme...

voila en fait je veux remplir une table avec vba, ca marchait impec jusqu'au jour où il m'a mit une erreur sur le rs.update "argument non valide".
apparemment c'est comme si sa capacité était dépassée, car j'ai copié la table en question, je l'ai recollée avec un nom différent, et ca marchait.
dès que je lui ai réattibué son nom d'origine, ca ne fonctionnait plus !

maintenant, je ne peux meme plus la copier, la aussi ca me met "argument non valide".
bizarre...
a l'aide please !

merci d'avance ;-)
0