Problème fichiers x avec le mesh viewer de ms

Signaler
Messages postés
268
Date d'inscription
lundi 1 mars 2004
Statut
Membre
Dernière intervention
19 avril 2012
-
Messages postés
196
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
1 mai 2009
-
Salut à tous,

voilà, j'expose le problème,

j'ai télécharger 'Deep Exploration' qui est le seul (à mon avis) à bien exporter un formazt de fichier tel que 3ds, max, cob, lwo en fichier x.

Donc j'avais télécharger le mesh BIOSHIP sur trekmeshes.ch (pour le coup, j'ai pris le LWO) et je l'ai exporté avec les textures en .x

Le problème, c'est que quand j'ouvre le mesh .x avec le mesh viewer de microsoft, le mesh n'est pas texturé (il est tout vert).

Pourtant le mesh et les textures sont dans le même dossier et les textures sont
en *.bmp.

Ce qui est incompréhensible, c'est que sur certains meshes les textures sont lus

Après je ferme deep exploration, je le rouvre et je réouvre le fichier x et là les textures aparaissent bien.

Est-ce que quelqu'un sait pourquoi le mw de ms ne fonctionne pas si bien que ça (vous pouvez même faire des tests puisque je vous donne le matos que j'utilise) et connatitrait t il où je pourrez trouvez le code source du deep exploration pour retrouver la façon dont les exportations fonctionnent.

Je sais bien que le sujet est complexe, mais si vous pouvez m'aider, ce serait sympa.
Allez @+

1 réponse

Messages postés
196
Date d'inscription
mercredi 6 août 2003
Statut
Membre
Dernière intervention
1 mai 2009
2
salut, je pense que cela peut provenir de bugs issus des logiciels exportant au format X. J'ai eu le même problème avec Cinema4D XL6. Les fichiers non texturés fonctionaient sous le Mesh Viewer de Ms mais dès qu'une texture était ajoutée, cela plantait. Même chose aec les conversions faites à une époque avec certains prog gratuits. Les fichiers en .X provenant de Truespace 3.2 fonctionnent à peu près bien.

LaPatoshe