Paramètre pour VLOOKUP - Help me

Messages postés
4
Date d'inscription
mercredi 9 octobre 2002
Statut
Membre
Dernière intervention
5 mars 2003
-
Messages postés
42
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
20 mai 2005
-
Hello

Je vous expose brièvement mon problème.

Je suis sous Excel 2000, j'ai la formule suivante :
=RECHERCHEV($A6;'\\chemin d'accès...\[prod40.xls]Mercredi'!$A$1:$E$4488;4;FAUX)

Ce que je souhaite c'est saisir dans une cellule le numéro de semaine par exemple 39 et modifier la fonction RECHERCHEV comme ceci :
=RECHERCHEV($A6;'\\chemin d'accès ...\[prod39.xls]Mercredi'!$A$1:$E$4488;4;FAUX)

Qui a une piste ?

Merci @ tous
Mickael Kael for CNN International

1 réponse

Messages postés
42
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
20 mai 2005

Il te suffit de lancer la recherche de cette maniere:

ThisWorkbook.Worksheets(feuille_saisie).Range("E" & ligne_depart + 1).FormulaR1C1 = "=VLOOKUP(RC3,[" & fichier_reference & "]references!R8C2:R608C10,3, false)"

Il te faut jouer avec les & et les " .

Voila m'sieur,j'espere que cela t'as aide!

:-p Ha que merde je me suis shtroumphé ;-) :big)